Firefox not starting maximized anymore

It used to start fully maximized, but for a while now I’ve noticed no matter in what state it was closed, it starts the same size as desktop is in size, but not maximized and this is driving me nuts as tabs are not aligned from the left edge, but they start 1cm away from the edge. And it doesn’t behave like a maximized app, it behaves like windowed app that’s the same size as desktop. It’s official Firefox from Manjaro’s repo (not Flatpak or something else). I’ve observed this on 2 totally different laptops, one runs AMD’s Ryzen 5 and the other runs Intel’s Pentium N6000, both are running latest Manjaro KDE.

Why is it not starting maximized, the way I want it?

Hi @RejZoR,

This I can’t tell you. I honestly didn’t even know it did that initially. However, I see you use KDE, just like me, and I’ve long ago setup a Window rule to do just that. (And position it on my primary monitor always.) To do so:

  1. Go to LauncherSystem Settings.
  2. In the settings window that opens, go to WorkspaceWindow ManagementWindow Rules.
  3. There you can set it up.

a Screenshot for reference:

Hope this helps!

1 Like

It does the same thing on Windows. I don’t know if they’re trying to make all instances of Firefox more unified to make it harder for sites to fingerprint or if it’s just being stubborn.

In de KDE System Settings:arrow_down:

Workspace → Window Management → Window Behavior → Advanced tab


Untick the box next to “Allow apps to remember the positions of their own windows, if they support it”.

1 Like

Ok, this is ultra bizarre. I’ve added the rule for KDE to ignore Firefox’s request on Windows size. And it obeyed that, kept maximized on start, even remembered when i made it small and closed. But this isn’t the bizarre part. The real bizarre part is that after I removed the Window rule (now there are no rules), Firefox remembers the behavior now. It starts minimized, it remembers being smaller than desktop, even after app restarts. I’m gonna restart the system now to see if it’s not just remembering for this session…

Yup, this fixed it permanently for some reason. I don’t have any rules in those settings, yet Firefox behaves correctly again. That’s super bizarre. I just hope it’ll be fixed by whoever is causing this, be it Firefox or KDE (or Manjaro’s implementation of both). I don’t want to be chasing solutions for this 2 years in the future because I’ll reinstall Manjaro clean or something like that…

This didn’t fix anything for me. I had to add rule with “Ignore requested geometry” and select “Remember”. And Firefox is now remembering the window size and position even after I’ve removed this rule from the Window Rules entirely. Which is weird, but Firefox now behaves as it should again.

My “fix” got reset after today’s big update. I had to reapply it again. This has to be a bug because this isn’t how Firefox should be behaving. In fact no app should be behaving like this.

I’ve had this problem before which I asked about here:

Not only the self proclaimed “solution” (I certainly didn’t flag it as one, because it didn’t work even back then) by the user Aragorn there did absolutely nothing back then it still does absolutely nothing now. The worst part is, MY OWN fix that worked back then doesn’t work anymore.

I’ve set the rules to ignore requested geometry and make it remember and that fixed the issue but now even that doesn’t work anymore for some reason. And every time I start Firefox, it starts in window mode that just fits into display view instead of being actually maximized. And the damn thing isn’t remembered even if I maximize it and close it. You may say it’s unimportant, it’s “full desktop view” anyway, but when it starts this way, tabs are not listed right next to top left corner, but with 1cm space and that’s super annoying. Where if you maximize it, tabs are right next to corner. When using just touchpad and not proper mouse, it’s very annoying for navigation.

Why is this happening and more importantly, why is my fix suddenly not working even though it was before? Why can’t this just freaking work? This is elementary stuff expecting apps to remember last used window size and state aka being maximized. I don’t get it.

Have you tried re-enabling the setting for applications to remember their own geometry?

That said, I myself am having issues with certain applications ignoring window rules as well, so I suspect that this may have been broken at some point when Plasma was upgraded to 5.24.7, and that it would be an upstream bug.

As for the solution, I have unmarked it, reopened the original thread and merged your new thread into it. Are you happy now? :smirk: :stuck_out_tongue:


This time I had to use “Maximize horizontally” and “Maximize vertically” and set both to “Remember”. This way it seems to open maximized when I leave it this way last Firefox use and seems to remember windowed when I leave it that way. I just don’t know why is this a thing and why my last fix stopped working. Now I fear the day when this fix will suddenly stop working again…

I wish this wasn’t necessary in the first place…

For me on plasma it remembers to start maximized. I had the problem of it not doing so about a year ago, but after that a FF update made it work and it has just worked ever since. So i would think the issue is with some cache/config files so maybe clear those?

For me it was working fine and after Manjaro update dropped, it stopped remembering. At which point I don’t know if it’s KDE’s issue or Firefox’s since both were updated at that point.