Firefox-nightly has a proper .desktop file, but shows incorrectly on dock after changing profiles

I installed firefox-nightly from the AUR after reinstalling manjaro (gnome edition this time) and everything worked fine, but after inserting the backup of my profile suddenly it’s wonky. The “Firefox Nightly” icon in the app drawer still launches the browser properly, but when other applications try to open a link I get a “firefox is already running” error.

On top of that, the icon in the dock shows up as a grey gear with no options to “favorite” or “show details”, as if it was just a command that was running or something. Here’s a picture:

I’ve tried reinstalling the package to no avail. Any help would be appreciated, as I haven’t used Gnome since 3.2 probably.

I think to refresh Firefox or install the package AUR a new.

Neither refreshing, nor reinstalling the AUR package worked.

Is possible that the adressing of icon is not correct. There, I can’t help you anymore because I not use Gnome.

did you get a solution? On Gnome I have the same problem…

Same issue here as well…