Firefox memory leak and crashing

Hello all! I am having issues with Firefox that is causing it to memory leak and crash after running for about 10 minutes. I tried uninstalling it using yay -R firefox. I tried starting it in safe mode, no change. Updated it to version 92.0.1-1, still no difference. It will use up to 4GB of memory and load the CPU to 100% then crash. I’ve tried absolutely everything and am fresh out of ideas.


… and you have provided no system information at all
and/or whether your system is fully up to date

… you tried “everything” - but what does that mean? :wink:

Those symptoms are often due to:

  • the sites you browse
  • the number of tabs of have open simultaneously
  • the extensions you use

Have you already checked those?

1 Like

It crashes when nothing is open beside the homepage (Bing). When running with a clean profile where all the settings have been reset to default and the extensions are disabled, it continues. I can’t do anything inside the browser as it’s gotten worse since I posted the thread, now it hogs memory only after being open for 15 seconds and usually crashes within the first minute of being open.

As for specs: Dell Inspiron 15 3565, AMD A6-9200e, 8 GB of memory, running XCFE Pahvo 21.1.4, Kernel 5.9.16-1.

I can’t seem to upload any photos or links either.

you can post links when you format them differently - like this, for example:

(format as “blockquote” - highlight and then use the " button in the top row of the edit box)
or use the next one (</>) - preformatted text
Photos or screenshots are … suboptimal.
Avoid if you can.
You can upload them to an external site, then post the link to that here.

Try downloading the compressed file (tar.bz2) from the official mozilla website, unzip it in the folder you want, rename the .MOZILLA folder (so that this firefox creates a new folder) execute the file firefox or firefox.bin and see if has the same problem. This “original” version of mozilla does not need to be installed (it works as a portable version) it is not updated via manjaro repositories but it does so when firefox is active (similar to the windows version).

This might give a few ideas.

1 Like