Firefox mailto: does not open Thunderbird new message dialog nor prompt (Always ask)

It is longer term issue.
when i click some e-mail on a webpage in Firefox (mailto: link) nothing happens.
I have checked and in Firefox about:preferences#general is mailto set to Thunderbird.
I have tried to set Always Ask instead, but no prompt. Not restarted FF after this change.
Thunderbird is running.
Private window also no action.
Other browser opens TB new message dialog.
When i search for default, and open Default apps, TB is set as default.

$ uname -r;firefox --version;thunderbird --version
Mozilla Firefox 94.0
Thunderbird 91.3.0

check your ~/.config/mimeapps.list

$ grep mail ~/.config/mimeapps.list


$ locate xfce4-mail-reader.desktop

$ head -n 15 /usr/share/applications/xfce4-mail-reader.desktop

[Desktop Entry]
Exec=exo-open --launch MailReader %u
Name=Mail Reader
Name[ar]=قارء البريد الالكتروني
Name[be]=Паштовая праграма
Name[be@tarask]=Чытач пошты

when i run from cmd. line: exo-open --launch MailReader %u it launches TB new mail message window.

whisker menu, type “Default”, click Default Applications, Mail reader is set to Thunderbird…

It works as expected on my end.

logoff - login then open Firefox and type in address bar

If it doesn’t open thunderbird you need to investigate your configs.

grep -rl 'mailto:' ~

As mentioned, this is long term issue, i have logged in like yesterday, when i execute “” in a new FF tab, it does nothing. Neither Private window or FF Troubleshooting mode. Other browser handle mailto: OK.

grep -rl 'mailto:' ~

.firefox and .mozilla folders does not seem to contain any matching conf file

Hello postcd,

I have take a look in ‘about:config’ in FF. If the switch


is set to false it also didn’t start Thunderbird at my place. With set this to ‘true’ it works as expected.

Please prove to which value it is set. When other browsers do it well I think theres a problem with FF config. :grinning:



Thank You all. Issue solved. You were right, this was Firefox misconfiguration. I apologize i have not checked about:config
Indeed i had it set to false (unsure why) which is non default state.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.