Firefox lost most menu options

Firefox version 118.0.1
After rebooting system, firefox does not allow to select most menu entries. I can get bookmarks and history, but not setup. All File options are blanked out. This happens only with my profile, when I select other, it seems to work fine. I did try to restore several backup versions of ~/.mozilla, it makes no difference.
This is a big issue for me, since I have not exported my passwords. What are my options?
I just noticed the version 118.0.1-1 is available. Should I try it first?

Works now. What I did:

  1. Started firefox in a safe mode:
firefox --safe-mode -P
  1. Selected my profile
  2. Disabled all extensions
  3. Restarted firefox normally (i.e. without arguments)
  4. Enabled extensions
  5. Restarted firefox again.

So, I am back with the original configuration. Problem “solved”, at least for now.

An ‘original’ is always created when you create a new profile.

The ‘previous’ profile should be stored in backups and snapshots, so that you can simply move your profile → profile.CURRENT and copy in a snapshot/backup.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.