Firefox keeps completely freezing randomly

i’ve uptate to 107.0 and no freeze after many hours of using ff .
You can use mozregression to verify .
“mozregression --find-fix --repo=mozilla-release --good 107 --bad 106.0.5”

in my case problem solved .

I have a similar problem about firefox in the KDE. Suddenly, ff got freezed. In fact, the title bar, therefore the closed button, of ff disappears. In fact, the title bar of other applications also disappear. Moreover, the panel of kde also disappears and I can’t change to other applications by shift+tab.

I don’t know wether this is a KDE problem or a ff problem. But it seems very similar to the bugs discussed in this topic.

1 Like

Nope, still immediately freezes after trying to open the Downloads window.

1 Like

Hi, I’m also having the same issue. I’ve tried downgrading firefox from 107 down all the way to 105, and it still froze from time to time. I’ve also tried changing kernels and disabling hardware acceleration to no avail.

For me the freeze didn’t happened when opening the download page, but when copping text either from firefox or to firefox.


I’m also experiencing sporadic freezing issues again as well. For me, the issue is on-again, off-again for weeks now after experimenting with different acceleration options. Some problem correlations are multi-monitors, video streaming, and problems when attempting to open (or switching to) new tabs or instances. Can anyone please post any recent core dumps from journalctl? I still don’t have any items in about:crashes. Maybe (if not hw-related), explore UI/theming issues again?

a recent core dump of mine

systemd-coredump[31550]: [🡕] Process 31548 (firefox) of user 1000 dumped core.

                                           Stack trace of thread 31548:
                                           #0  0x00007fdab8a79874 XDisplayString ( + 0x2b874)
                                           #1  0x00007fdab77f4a1d __vaDriverInit_1_13 ( + 0xda1d)
                                           #2  0x00007fdaab755c9c n/a ( + 0x3c9c)
                                           #3  0x00007fdaab75adf1 vaInitialize ( + 0x8df1)
                                           #4  0x00007fdab4151347 n/a ( + 0x8751347)
                                           #5  0x00007fdab4151f1e n/a ( + 0x8751f1e)
                                           #6  0x00007fdaaff6ccde n/a ( + 0x456ccde)
                                           #7  0x00007fdaaff6a31d n/a ( + 0x456a31d)
                                           #8  0x00007fdaaff5c2b5 n/a ( + 0x455c2b5)
                                           #9  0x00007fdaaff5b46d n/a ( + 0x455b46d)
                                           #10 0x000055db27a84cec n/a (firefox + 0x58cec)
                                           #11 0x00007fdaba83c290 n/a ( + 0x23290)
                                           #12 0x00007fdaba83c34a __libc_start_main ( + 0x2334a)
                                           #13 0x000055db27a94cc5 _start (firefox + 0x68cc5)
                                           ELF object binary architecture: AMD x86-64
1 Like

I’ve problem with Firefox
Its non functional after latest update.
I could tray reinstalling, starting with debugger mode and so on but unfortunately couldn`t get any visual piece of Firefox. Its looks like frezed window contain noting. Catches other window’s visuals. Can be related X11 maybe. Because its renders nothing.

firefox --version
Mozilla Firefox 107.0
██████████████████  ████████   axe@axe-inspiron3585 
██████████████████  ████████   -------------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: Inspiron 3585 1.4.0 
████████            ████████   Kernel: 5.15.78-1-MANJARO 
████████  ████████  ████████   Uptime: 1 hour, 18 mins 
████████  ████████  ████████   Packages: 1871 (pacman) 
████████  ████████  ████████   Shell: bash 5.1.16 
████████  ████████  ████████   Resolution: 1920x1080 
████████  ████████  ████████   WM: i3 
████████  ████████  ████████   Theme: Adapta-Nokto-Eta-Maia [GTK2/3] 
████████  ████████  ████████   Icons: Papirus-Adapta-Nokto-Maia [GTK2/3] 
████████  ████████  ████████   Terminal: urxvt 
████████  ████████  ████████   Terminal Font: 9x15,xft 
                               CPU: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx (8) @ 2.000GHz 
                               GPU: AMD ATI Radeon Vega Series / Radeon Vega Mobile Series 
                               Memory: 2555MiB / 5823MiB 

I couldn’t manage to get coredump file from gdb which I applied these steps.

coredumpctl list|grep firefox
coredumpctl list|grep 1116

Just I`ve following…

cat /proc/1116/cmdline 

Could you clarify more, how can I get it? Because I’ve also problem with firefox

@maxemilian, just take a look if you have any obvious error entries since your last boot: $
journalctl -b -p3 --no-pager --no-hostname

Here it is no notable thing…

Nov 20 14:01:07 kernel: tpm_crb MSFT0101:00: can't request region for resource [mem 0x4f76f000-0x4f772fff]
Nov 20 14:01:07 bluetoothd[484]: src/plugin.c:plugin_init() Failed to init vcp plugin
Nov 20 14:01:07 bluetoothd[484]: src/plugin.c:plugin_init() Failed to init mcp plugin
Nov 20 14:01:07 bluetoothd[484]: src/plugin.c:plugin_init() Failed to init bap plugin
Nov 20 14:01:17 lightdm[729]: gkr-pam: unable to locate daemon control file

We might have different issues. Maybe it’s still worth checking like a week back versus last boot.

journalctl -p2 --no-pager --no-hostname --since 2022-11-13

1 Like

Okay, tested 2 Laptops AMD Powered.

Older HP Laptop, AMD FX with Radeon R7, does this: I have a problem with Mozilla Firefox

And the Newer Laptop, Acer Ryzen 3 with Vega works as it should!!, No problems!!

So not sure whats going on With Manjaro/Firefox?

You know what’s funny about my situation when ff decides to randomly stop? My old friend, the frozen-window desktop snake effect is back if new apps are launched and dragged on the current workspace. I missed seeing this from back in the day, it’s a cool effect. :sunglasses: :cold_face:

P.S. I did a firefox “refresh” and cache blown away, no effect.


I couldn’t catch with grep anything

journalctl -p2 --no-pager --no-hostname --since 2022-11-13|grep firefox

but here entire sniped

I’ve good news! Firefox running normally now!
Firefox begin to run around first working day stress. Great… I need its extension you know life changer.
I didn’t even restart but it is in well situation now. Thanks for any help. :heartpulse:

1 Like

Good to hear. I’ve simply disabled all acceleration again and I believe that’s the root issue for me:


1 Like

Is the 2022-11-14 “Known Issues and Solutions” issue as to libx11-1.8.2 as per [Stable Update] 2022-11-14 - Kernels, GNOME 43.1, Plasma 5.26.3, Systemd 251.8, Firefox 106.0.5, Thunderbird, LXQt - #2 by philm relevant for you’z people?

Nice to see the edit there by @alkl but my issue may be unrelated to highlighting text, but ultimately with the same freezing outcome. Disabling hw acceleration completely is a fine workaround for now.

Also, I figured out a reproduction. When hw acceleration is enabled, and ensuring window grouping is disabled in xfce’s window panel settings, then in ff select: hamburger → downloads, and with the firefox downloads window (labeled as “Library”) visible in the taskbar, keep fastly left-clicking it (there in the taskbar) to keep minimizing/unminimizing it until the entire window fails to paint, causing ff to freeze entirely. For me, it’s around the ~7th unminimized click before the window fails to paint.

No, Never had this problem on either 106.5 or 107.0, On Desktop I7, still have the NVidia Hardware acceleration bug, Turn it off or crash, and an older AMD K8/Radeon Laptop is the problem with Firefox not loading at all then finding it’s running 3 times in task manager, kill 2 below the top Firefox and then it loads, really annoying to do this every time i need/use Firefox, but again not the problem listed.

The issue with libx11 primarily happens when playing a video and copying something to the clipboard:

For me that freezing was instantly, when trying to Copy a password from Bitwarden (Firefox Addon) to the Clipboard, while playing a video. The entire Firefox process would come unresponsive. (Not even clickable, would crash with Alt + F4)

I also experienced an issue, where Firefox somehow caused the whole desktop environment getting unresponsive (idk if this is the one you all are referring to in this thread), only the mouse was working. Haven’t happened since I applied the libx11 patch.

Now the only thing left is that Firefox windows / tabs would come unresponsive (UI element not clickable / closing a tab would leave an empty space) at some point.

It seems that there are two - three issues at play at the same time, at least for me.


Do you got any journalctl dumps we can look at? :face_with_monocle: