Firefox keeps asking to be default browser even though it is. Plasma

It’s a small annoyance but firefox doesn’t think it’s my default browser. I’ve double checked system settings, file association, mime-types - when I go into FF preferences I click “Make Default” and it doesn’t change. If I click on a downloaded .html file FF does launch. Everytime I start it, it asks to be default. Any help?

1 Like

Firefox menu → Preferences → Always check whether Firefox is the default browser

Disable the check there.