Firefox KeepassXC AutoType

Hello folks,
i am experiencing some issues with the KeepassXC auto type function and Firefox. I configured everything as explained in the KeePassXC documentation, but it doesn`t work… The thing is if i try the auto type with chromium, everything is working as expected. :face_with_monocle:
Is here someone with the same issue, or someone who can help me?

my setup:

  • Firefox installed from the offical repo (no flat or snappaket)
  • latest Manjaro release with gnome desktop

Hope someone could help me.
Regards izumit

Link please?


As you can see, there is not much to do

I don’t remember having changed any configuration there, and i regularly use it on Firefox without any trouble.

Can you describe your usual use-case (global or entry mode, activation through shortcut or toolbar icon, etc.)?

i open my firefox, browse to my website, click on the login form and press CTRL+Shift+V (my shortcut set in KeePassXC) and nothing is happening. The same Steps in Chromium are directly running the autotype and login.

Other strange thing is, when i want to add the Auto-Type in KeePassXC for an entry, i only can choose chromium in the “Window Associations” Firefox isn`t shown here…

Probably because this is also used by Firefox.

Do you have a Firefox window open?

I think that is not the problem, I changed it to another and the same problem occurs again

yes :rofl: i can see all windows like chromium discord and so on, but firefox isn`t shown…

Does it at least work through KeePassXC’s toolbar button?

no keepass is closing but nothing else happens

At least i know that is not normal, since it is what i usually use.

Have you tried launching KeePassXC from the terminal, and see if any error is printed there when you try to autotype into Firefox from the toolbar?

i’ve tried, but no errors shown up

This hits me only now.

And GNOME uses the Wayland display server instead of X11.
I was thinking, the issue may be with Firefox instead of KeePassXC. You did mention that Firefox windows do not show in the list for the autotype configuration. And reading this :point_down: Firefox may run on X11 by default, which would explain everything.

i think that’s the error… when i look up about:support it reports this:
Mozilla/5.0 (X11; Linux x86_64; rv:94.0) Gecko/20100101 Firefox/94.0

Now i am trying to change it to wayland, but at the moment it isn’t working and always starts with X11 again

Edit: Now it starts with wayland, but KeePass still doesn’t show firefox.

I’m getting out of ideas.
From what i find, Wayland isn’t officially supported yet, even though many people don’t have trouble using KeePassXC with it.
Alternatively, you could try using an add-on in order to use Autotype in Firefox: KeePass - ArchWiki

You can try if autotyping works with wayland:

keepassxc  -platform xcb

Yeah i am also running out of ideas. Maybe i will make a new clean setup and try it again.
I will let you guys know.

no changes…

I use KeePassXC too, but for auto typing in Firefox I use KeePassXC-Browser extension: GitHub - keepassxreboot/keepassxc-browser: KeePassXC Browser Extension

In KeePassXC in Settings → Browser Integration, enable for Firefox.
You can try this option, although I have not tested it on Wayland.

For the record, i use Xfce, so not Gnome nor Wayland.