Firefox fonts problem

I’ve reported this as a bug in bugzilla, but it seems that nobody is looking at it…and it’s so annoying :S i’ll leave here the link to it: 1766567 - Font changed in some sites but also put the description here:

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:99.0) Gecko/20100101 Firefox/99.0

Steps to reproduce:

If i enter some sites, the font changed after i’ve installed some fonts in Manjaro with Gnome in this folder with admin privileges /usr/share/fonts and then the error began to happen :S

Actual results:

The font changes on this sites for example:

Expected results:

Show the sites with their normal fonts

From that wording, did you manually install those fonts? Or did you use the package manager?

Do you still have the issue after rebooting?

Do you have Allow pages to choose their own fonts, instead of your selections above checked in Firefox’ settings?

1 Like
  1. What fonts?
  2. Did you use the package manager?
  3. What means “normal” and what has been changed?

Please consider installing fonts by hand only in your home folder at:


1 Like

I’ve copied them from a folder to /usr/share/fonts/TTF with admin privileges…didn’t know i could use pamac for that…so do i need to go one by one installing them from there? what if they don’t appear?

Yes the problem still here after rebooting :face_with_diagonal_mouth:

And yes, i’ve that option activated, look:

I have a folder where i put all the fonts i like and take them to any computer, they are like 100, but didn’t overwrite any.

No, didn’t know i could do that :S and not all the fonts appear there :face_with_diagonal_mouth:

I think you can see that accents in spanish show weird and also the font itself its pretty hard to read :face_with_diagonal_mouth: i’ll put a comparisson here (cause in chrome it works just fine)

And couldn’t open that path :face_with_diagonal_mouth: look:

You can create that folder, so you can then manually put your fonts in it.

mkdir ~/.fonts


You have to click on “Avanzadas” to see if the option is checked, it should be by default.

Yes, sorry, that’s what i did, but when printing the image from firefox, didn’t printed the pop up of advanced options, i’ve updated it. Thanks :slight_smile:

I tried on Ecosia, if the option is unchecked, my font is used, if not, it’s the website font.

IT WORKED!!! everything back to normal!!! :smiley: THANKS A LOT!!! so, next time, i just create that folder and put all my fonts and voilá, it’s even faster than having to open the other one as an admin! :smiley:

Ok, but how can i restore the other folder where i’ve put all the fonts? cause what I did was to order them in last modified order and selected the last 100 :stuck_out_tongue: and moved them to the new .font folder and that was how it worked…but hope i didn’t moved an important Manjaro font :stuck_out_tongue:

And just, one final doubt, what’s the difference between this two? cause i’ve only created and moved all the font files to the fist one.

Generally speaking, for casual users, system wide installation shall be left to the package manager. Users can “install” something within their home, not requiring superuser privileges to install, run, and remove it.

Well, that was something you could have checked before moving the files. For instance, selecting only the files modified within the last day was very possible…
If you have a backup of your system, you could check what’s in it.

Manual installation

The recommended way of adding fonts that are not in the repositories of your system is described in #Creating a package. This gives pacman the ability to remove or update them at a later time.

Alternatively, fonts can be installed manually:

  • For a single user, install fonts to ~/.local/share/fonts/.
  • In many cases this suffices, unless you run graphical applications as other users.
  • In the past ~/.fonts/ was used, but is now deprecated.

Fonts - ArchWiki

I thought ~/.fonts was the current standard, oops! Well, it’s easy to fix.

mkdir -p ~/.local/share/fonts
mv ~/.fonts/* ~/.local/share/fonts
rm -d ~/.fonts
1 Like

Ok, lessons learned, but for now, it’s not working because surely y did something with the fonts, so, changed it to the ~/.local/share/fonts but still not working right :S

Is there a way in which someone could copy that folder (/usr/share/fonts/TTF) on a google drive and send me the link so i can download it and overwrite it? maybe that will solve my problem and won’t do that mistake again :frowning:


Why not using the package manager?

sudo pacman -S $(pacman -Qoq "/usr/share/fonts/")

Sorry, i’m not a programmer and just changed from Windows to Linux, i’m in learning curve… :stuck_out_tongue: and what does that do? it resets the folder in sort of speak? that would be awesome! :smiley:

It queries the database for installed packages, which owns that install path.

pacman --query --quiet --owns "/usr/share/fonts/"


sudo pacman --sync

reinstalls again the printed packages from above.

Together in short form:

sudo pacman -S $(pacman -Qoq "/usr/share/fonts/")

So to speak: it resets the paths to default, if you deleted something by accident.

OR if you need fonts, try this:

List all fonts packages:

pacman -Fq "/usr/share/fonts/"
pamac search --files "/usr/share/fonts/"

List files of a package:

pacman -Fl noto-fonts
pamac list --files noto-fonts
1 Like

AWESOME!!! Thanks for the explanation! i did it and yes, i had 145 fonts after i took away the ones i thought i’ve added, and now it has 171…so, let’s hope this works and i will never touch those folders :stuck_out_tongue: well, at least until i’m sure of what i’m doing :stuck_out_tongue:

But unfortunately, noup, it didn’t solve the font problem in Firefox pages :confused: and now it also happens in instagram and facebook, where do you think the problem could be? i’m going to erase the folder ~/.local/share/fonts to see if that’s the problem.

YES!!! it worked! but then, how should i install my fonts? and how do i know which one is causing the problem? :confused: now i’m afraid but i need to use different fonts :confused: don’t understand why that happens only with Firefox… :confused: is it a bug? what do you recommend me to do? does it happen only to me? :confused: jajaja…sorry, i’m a bit frustrated here :stuck_out_tongue:

Just a hint: If there is the same font name at home folder and at the global folder, then the home folder is always prioritized. Therefore I would check for equal names. Obviously the font at your home folder must have the same name as in the global folder, but its formatting is different.

1 Like

Ufff…ok, so i should review it one by one instead of just adding all my 100 selection :stuck_out_tongue: well, thanks for everything to everyone who helped here :smiley:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.