Firefox font rendering issue

Some monospaced text does not properly render capital E (it appears as a blank space). This is independent of any extension or setting (persists after deleting ~/.mozilla), and does not appear in the Firefox flatpak.

I am using an up-to-date install of Manjaro GNOME with nvidia graphics on Xorg.

Give a precise example?

You should verify that you have ttf-dejavu package installed.

Try changing your default font in the Preference section.

2 Likes

ABCDEF. On my screen this is is indistinguishable from ABCD F.

Yep, ttf-dejavu is installed. The problem goes away if I force Firefox to use a custom font for all monospaced text instead of allowing sites to use their own fonts. Changing the default font does not help.

I understand this as you saying it is a site specific issue? Then it is not a bug.

I can’t guess what you know about HTML, CSS and page rendering - so I will explain - in general terms what happens when you open a document in a browser.

All fonts used in a document usually defines one or more fonts defined directly in the document or using CSS.

If a specific font is used on any given webpage Firefox will render the font if available on the user’s system.

If the specific font is not available Firefox will pick one from the same family and if that fails Firefox will use what it think is the best alternative.

My only guess now is that something must be wrong with my fontconfig settings, though I haven’t altered them by hand on this install, as far as I can recall. I tested a fresh Manjaro GNOME live image, and Firefox was working properly there.

For reference, the problem was with the suggestion given by the install script for the ttf-nerd-fonts-symbols-mono package:

Symlink /etc/fonts/conf.avail/10-nerd-font-symbols.conf to /etc/fonts/conf.d/
or copy and modify as needed.

Removing the symlink in /etc/fonts/conf.d/ fixed it (and didn’t seem to break my nerd font symbols, so I’m not sure what it was doing in the first place?).