Firefox doesn't work... sometimes

Another option to replace Firefox is Waterfox, its in the AUR. I use waterfox-current-bin to cut down on the compile time. I was having crashing issues with firefox some time ago and switched. So far no problems and I cant tell the difference other than the name. One advantage is it is better at using the system theme.

waterfox-current-bin is outdated by like 2 years
Current packages are:
Waterfox G5 waterfox-g-bin
Waterfox Classic: waterfox-classic-bin

Waterfox is under development, not sure why the bin package is old. Waterfox will update itself if the folder is writable by you, which is what I have. The g5 is the latest branch, but that package is flagged out of date as well. You could just go over to the Waterfox site and download the linux version. It doesnt need to be compiled and will run out of its folder, but you would have to create a launcher and put it in /usr/share/applications to add it to a menu.

Tried waterfox, it works, but it messed up my firefox sync by resetting my themes and containers and its based on the LTS release of firefox instead of the latest one.
I just want firefox to work, is that too much to ask from one of the most popular distros?

“Welcome to my wold, wont you come on in…”

I feel your pain. First it was Firefox crashing, so I went to Waterfox. Then I tried Chrome and used it for a few months. I had it all working nicely and really liked it. After an update any Chrome based browser crashes instantly when clicking on it. I went back to Waterfox and have looked for fixes to no end.

This isnt a post for help, just sharing misery. I wish you luck in solving the issue you are having.

It looks to me, that you changed “alot”… maybe to much?

Can you remember when firefox the first time has problems? Maybe a Addon that causes this problems?

Possible a problem with xfce… who knows. Im using Manjaro KDE with 5.15 LTSC and adjusted with alot custom settings. And no issue at all, since above 2 years Manjaro time.

But i also had a VA-API error in Firefox that caused errors in Journal, few month ago… but firefox was still working fine, even with that error messages:

Here is it, how i solved this VA-API problem:

I hope it helps.

It is not clear, from where the problems of Firefox come from.
Normally, this is caused by damages of .mozilla in your home folder.

Nope it won’t be a problem with profiles only with mesa.
On a clean arch it doesn’t work either
You can get around it by launching the window a dozen times calling the error window that the app is already working.
Until the next reboot it will work and run.
I am sure it is mesa
Well, and now for amd there are 2 choices (I do not know what pc the author has, I do not want to read and for nvidia I would not know the solution either)
1.force amdgpu if it is not enabled this often solves the problem (not 100% sure)
2.install 32 bit packages for recommended packages for amdgpu or ati drivers (see wiki 32 bit packages for mesa) because it helped me once.
Well 3 is to wait for firefox or mesa update and check.
There I know that on manjaro there is already prepared profile of this firefox and settings etc but on arch it is clean and also doesn’t work so it’s not the profile’s fault

I just ended up switching to Firefox ESR, works flawlessly. Didn’t like waterfox

it had problems ever since I installed manjaro and did the system upgrade, almost out of the box. I did some minor changes to my system.

tried cleaning the profile

This got even worse since the latest stable manjaro update (with firefox 108)
Now it NEVER starts and sometimes, like with a 25 percent chance exits immidiately with exit status 1, without any error messages

PC problems could be a nightmare sometimes, it also could be related to a USB Device that is connected, try to remove all possible devices that are not required, or the SSD has damaged blocks.

Maybe give Manjaro KDE a try?

After solving my issue with Chrome based browsers, I wonder if something similar is happening here. My issue was a cursor theme, it caused Chrome based browsers to crash. I would set all the themes to default ones and see if the Firefox issues go away. If they do, replace one theme at a time to see which one is causing the issue.

i use a crappy old hdd lol, but i’ve just switched to firefox ESR (Extended support release) (which is based on firefox 102 and only receives security updates) and it works flawlessly

Appreciate this is an old thread, but my comments might be of use to others.

I had exactly the same problems with firefox as listed above so switched to firefox-esr after reading this thread. The install process pamac install firefox-esr was pretty bumpy - a whole load of error issues came up during the install. But surprisingly it still worked despite all the error messages - and it seemed to solve the profile issue. Then a routine update was released (I tend to do most of my updates on the terminal with pamac update) - and this one again gave loads of error messages but unlike before eventually aborted with no actual update. Not good.

I then thought I’d try a new approach - install Firefox as a snap. Install fine, current version and no profile problems. I’ve only been using this a few days, but I’m hoping I’ve cracked it. This is also the first time I’ve actually found a productive use for a snap package, up until now I’ve only ever tested but not used for real.

Using Manjaro Linux 22.0.3 Sikaris and writing this on Firefox 110.0 (Mozilla Firefox Snap for Ubuntu canonical-002 - 1.0).

Actually I installed plain Arch and still have the same issue again, three processes start and then hang. Maybe caused by Mesa or the radeon driver??
I may try using amdgpu because my gpu has experimental support for it.
I’m also using xfce just like in Manjaro.

If you want to give ESR a try, just use the binary package (firefox-esr-bin), no need to compile the whole browser.

esr probably still works but I don’t want to use an old version of firefox.

Thanks for the suggestion - but I got to the point where I just want things to work - which the snap version does…