Firefox Close Button Doesn't Appear When TItle Bar Is Not Used

Hello guys,

I’m kind of a new Linux user (about 3 months) and I really enjoy it but I have a few things that bother me.
One of them is that I don’t like the title bar from Mozilla Firefox but if I remove it, the close button disappears. I’m using Firefox version 106.0.2-1 from official repositories.

Can you guide me on how to fix this, please? Thank you!

You can’t, it’s limitation because of the GUI framework Firefox uses, you have KDE Plasma which is QT based and Firefox is GTK one, it will look weird, nothing can be done about that.
If you disable title bar, you disable title bar, there is no way to keep the close button there if you disable title bar in KDE settings.

EDIT: Actually, I might have been wrong, it is still very ugly but I found a way, right click on the firefox bar where are tabs into empty space and click customize toolbar, in left bottom corner click the Title Bar option.
It forces the close button on the tab bar but its on the left.

I already tried that but the only buttons that appear are Minimize and Restore Down, on the right. But on the left side, there is nothing. I could “trade” Restore Down with the Close button if I could because only the minimize and close buttons I’m using, but I don’t think is possible.
I really don’t like the title bar because it wastes so much space…

LE. I don’t know how to attach the print screens here, it doesn’t allow me to.

LELE. I installed Brave and on Brave I am able to disable title bar without any problems, but not Firefox.

If you have the Firefox icon on your main toolbar (Task manager) then right click that and select close.

I don’t know exactly what I’ve done or how but I was able to disable the title bar and the full buttons appear now (minimize, maximize, close) as they should.
I changed almost every setting from Settings - Appearance - themes and all of that. It had no change but after a restart, it seems something worked.