Firefox Clogged

Hello, I’ve noticed sometimes that my Firefox starts clogging and gets super slowed down to the point I can’t do anything in it. I’ve checked System Monitor and the PC is not overused, nor Firefox is using CPU extensively. All other apps work fine, I can also happen to be gaming meanwhile. It’s just Firefox that gets clogged.


I am on latest Manjaro, I have NVIDIA GPU with Nvidia Drivers… I can provide any info needed in case.

[HowTo] Request support

System info;

inxi -Fazy

Also, for firefox … make sure to check against your configurations, for example safe-mode;

firefox --safe-mode
System:
  Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=b7e18646-d767-43ac-a6ee-c8c28f449224 rw quiet splash
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: Z370 Pro4 serial: <superuser required>
    UEFI: American Megatrends v: P1.30 date: 10/24/2017
CPU:
  Info: model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 4364 high: 4393 min/max: 800/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4378 2: 4376 3: 4372
    4: 4302 5: 4378 6: 4358 7: 4340 8: 4382 9: 4358 10: 4393 11: 4389 12: 4342
    bogomips: 88824
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2060 SUPER] vendor: Gigabyte
    driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-11; EOL~2026-12-xx) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1f06
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.10 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.73x11.85")
    s-diag: 1102mm (43.38")
  Monitor-1: DP-4 pos: primary,right res: 1920x1080 dpi: 93
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  Monitor-2: HDMI-0 pos: left res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 2060
    SUPER/PCIe/SSE2 memory: 7.81 GiB
  API: Vulkan v: 1.3.274 layers: 5 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 2060 SUPER driver: nvidia v: 545.29.06 device-ID: 10de:1f06
    surfaces: xcb,xlib
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Device-3: Kingston HyperX 7.1 Audio
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-9:5 chip-ID: 0951:16a4 class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A mac: <filter>
  IF-ID-2: proton0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
Drives:
  Local Storage: total: 6.6 TiB used: 1.4 TiB (21.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO with
    Heatsink 1TB size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7
    temp: 53.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM006-2DM164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: CC26 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT250MX500SSD1
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 010 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD40EZRZ-00GXCB0 size: 3.64 TiB block-size: physical: 4096 B
    logical: 512 B type: USB rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
    tech: HDD rpm: 5400 serial: <filter> fw-rev: 4004 scheme: GPT
Partition:
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 154.24 GiB (67.7%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 8 GiB used: 127 MiB (1.6%) priority: -2
    file: /swapfile
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A gpu: nvidia temp: 59 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 54%
Info:
  Processes: 297 Uptime: 2h 59m wakeups: 0 Memory: total: 16 GiB
  available: 15.56 GiB used: 6.32 GiB (40.7%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1363 pm: pacman pkgs: 1353 libs: 413 tools: pamac,yay pm: flatpak
  pkgs: 10 Shell: Zsh v: 5.9 default: Bash v: 5.2.21 running-in: konsole
  inxi: 3.3.31





I notice your BIOS is very out of date.
(and updates include processor support, ram compatibility, speed, etc)
If my search-foo is correct
https://www.asrock.com/MB/Intel/Z370%20Pro4/index.asp#BIOS

Yeah probably, because I never touched my BIOS in my life

I have this problem on occasion, it’s always tied to bad code in advertising. I get those warnings, something to like “this website is slow.” I close FF and start anew without going to that website and everything is fine.

People should probably be making use of a (decent) adblock method.
I use a number of things … ublock:origin in the browser and optionally hblock on the system should be enough to avoid most problems.

PS:
For extra steps you can achieve something similar but better than noscript by using a minimum of medium mode with noop rules

* * 3p-script block
* * 3p-frame block 

No no I don’t get any site warning honestly.

Yes, I have UBlockOrigin, but I have this exact same Firefox build on Windows (copied the user profile to Manjaro) and it works flawlessly, so I don’t think it’s that

Know what’s better than thinking that?

Knowing it.

So try it with a clean profile first, that way you can know, because I don’t have that problem:

firefox --profilemanager

If that works for a day or so, longer than you’d usually have to be working to experience he issue, try your previous profile again, but disable all extension and themes. Enable them one-by-one to test them individually.

Once you’ve encountered the experience again, you know what theme/extension is causing it.

My guess is some extension causing havoc on Linux.

:man_shrugging:

1 Like

Firefox needs some kind of clean/refresh after certain time of usage, what I do normally is:

  • Clean browser cache
  • in about:support launch “Clear startup cache” and restart
  • If above steps do nothing, then in about:support Perform “Refresh Firefox”, it will remove your extensions and customization but keep your history, bookmarks and passwords.

I’ve never had to do this in the ±3 years’ Manjaro installation…

1 Like

I use many extensions with Firefox, and the first problems that always happen on my laptops after a period of usage is that the browser takes long time to start and to connect to internet, and also takes long time to load YouTube and Facebook websites. After doing those cleaning steps, my browser becomes fast again.

This is not a problem specific to Linux, on Windows 10 it’s much more severe, the browser always needs to be periodically cleaned and refreshed.

I do too. I think 85:

$ ls -lah ~/.mozilla/firefox/31vh7rnd.dev-edition-default/extensions | wc -l
85

…so I still suspect it’s some extension, but yeah, Windows is a lot worse.

I don’t run adblock because I want the sites I visit to make money so I can continue to read them for free. Besides it’s an infrequent problem I can deal with on my own. No desire to install 85 extensions, yikes, have fun diagnosing that.

I find the use of more than 1 or 2 a bit messy, beyond 4 or 5 is pretty much unthinkable.
Something like 82 (gotta subtract a few for non-ext directories and the .. . things created by the ls string) is probably a medical condition. :sweat_smile:

PS.
The ‘I allow ads on the whole internet because I want to support these handful of people’ is a very old (but not very good) argument.

Do you click on a few too, because they are click-generated revenue?
(otherwise they dont get the money?)

Or no, because they are time-leases so they are still supported?
(in which case they get the money regardless of you viewing it?)

And you really support website 456-doh.org to such an extent, that even when they serve you ads so horrible they crash your browser … that you still want to allow them all?

And whats to stop you from having it enabled on most services, but disabled when you really support bloggyblog123?

Etcetera … but … as I said, its old arguments, so a handful of the familiar hits are good enough for now.

:rofl: Not disagreeing with you! :rofl:

But it does serve to illustrate my point that “many extensions” is no reason for what he described…

I didn’t use to mind ads…when they weren’t half the page or more…now even the, supposedly “free” sites are clogged with 'em.

Similarly I didn’t use to have a worry or care about so-called bloatware on my phone. Until I remove most, if not all Samsung applications out of boredom and curiosity.

And the phones battery life skyrocketed. Literally doubled.

Not me having to diagnose anything.