Firefox choose folder got wrong when use a USB HDD

what happen

I use USB-SATA cable to connect my HDD for a long time. There days the firefox get some problem after I use qBitorrent delete some file on HDD.

When I choose file or floder in my HDD named 新加卷 from firefox, it will got this info:

I have change my display language into English and my firefox language still is English(US). Reboot to make sure language. It still display Chinese. The info means:

“Unable to read the content of HDD(新加卷). Get file “/run/media/kearney/新加卷/男士穿搭指南:用穿搭。。加分” info error: Input/Output Error”

The file named “男士穿搭指南:用穿搭。。加分” was deleted last night via qBitorrent.

I think it file choose dialog problem. But I try same thing with chromium. It is ok without any wrong info.

This Change Firefox file manager - #3 by Aragorn tells about kdialog. I try kdialog --getexistingdirectory. It show a dialog like that in chromium. So I do not know what is wrong with the firefox?

Anothoer wired thing is chrominum got all floders in that HDD while firefoe only got 6 floders.



$ inxi --admin --verbosity=7 --filter --width
  Kernel: 5.15.32-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=59df4062-2639-4b83-ae42-13e94479944d rw quiet splash
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82DM v: Lenovo XiaoXinPro-13ARE 2020
    serial: <superuser required> Chassis: type: 10
    v: Lenovo XiaoXinPro-13ARE 2020 serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0L77769WIN
    serial: <superuser required> UEFI: LENOVO v: F0CN35WW date: 04/19/2022
  ID-1: BAT0 charge: 47.2 Wh (95.9%) condition: 49.2/56.0 Wh (87.9%)
    volts: 12.7 min: 11.5 model: SMP L19M3PD3 type: Li-poly serial: <filter>
    status: N/A cycles: 171
  RAM: total: 15.06 GiB used: 4.13 GiB (27.4%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 4600U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600106
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1502 high: 2118 min/max: 1400/2100 boost: disabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1396 2: 1397
    3: 1535 4: 1397 5: 1397 6: 1613 7: 1397 8: 1397 9: 1397 10: 1397 11: 2118
    12: 1592 bogomips: 50322
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 03:00.0 chip-ID: 1002:1636 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-2:2 chip-ID: 04f2:b67c class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 168 s-size: 387x241mm (15.24x9.49")
    s-diag: 456mm (17.95")
  Monitor-1: eDP-1 mapped: eDP model-id: CSO 0x076d built: 2019
    res: 2560x1600 hz: 60 dpi: 227 gamma: 1.2 size: 286x179mm (11.26x7.05")
    diag: 337mm (13.3") ratio: 16:10 modes: max: 2560x1600 min: 640x480
  OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.32-1-MANJARO LLVM 13.0.1)
    v: 4.6 Mesa 21.3.8 direct render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 03:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 03:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.32-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: Lenovo driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 01:00.0 chip-ID: 10ec:c822
    class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3 chip-ID: 0bda:c123 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 775.03 GiB used: 491.11 GiB (63.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN730 SDBPNTY-512G-1101 size: 476.94 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 11130001 temp: 39.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB model: Mass Storage Device
    size: 298.09 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 120 GiB size: 117.72 GiB (98.10%) used: 78.83 GiB (67.0%)
    fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4 label: manjaro
    uuid: 59df4062-2639-4b83-ae42-13e94479944d
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 93.1 MiB (36.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: SYSTEM_DRV uuid: 92C4-DD2F
  ID-3: /run/media/kearney/a raw-size: 235.67 GiB size: 231.47 GiB (98.22%)
    used: 180.28 GiB (77.9%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
    label: a uuid: 3409b138-e5fc-412d-b1d5-bfb236f93257
  ID-4: /run/media/kearney/新加卷 raw-size: 298.09 GiB
    size: 298.09 GiB (100.00%) used: 231.91 GiB (77.8%) fs: ntfs dev: /dev/sda1
    maj-min: 8:1 label: \xe6\x96\xb0\xe5\x8a\xa0\xe5\x8d\xb7
    uuid: A0B68ED4B68EAA7C
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p5 maj-min: 259:5 size: 55 GiB fs: ntfs label: C
    uuid: 0AB232A4B2329463
  ID-3: /dev/nvme0n1p6 maj-min: 259:6 size: 65.98 GiB fs: ntfs label: D
    uuid: 127AE7467AE72567
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-2:2 info: Huasheng USB2.0 HUB ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 214b:7250 class-ID: 0900
  Device-1: 1-2.3:5 info: Super Top M6116 SATA Bridge type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 2mA
    chip-ID: 14cd:6116 class-ID: 0806 serial: <filter>
  Device-2: 1-2.4:4 info: Xiaomi MI Wireless Mouse type: Keyboard,Mouse,HID
    driver: hid-generic,usbhid interfaces: 4 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 2717:003b class-ID: 0300
  Device-3: 1-4:3 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:c123 class-ID: e001 serial: <filter>
  Hub-3: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-2:2 info: Chicony Integrated Camera type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b67c class-ID: 0e02 serial: <filter>
  Hub-5: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 45.0 C
  Fan Speeds (RPM): N/A
  Processes: 307 Uptime: 49m wakeups: 1 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1618 lib: 420
  Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15


  • firefox 99.0.1-1(update to 100.0 today afternoon)
  • chromium 101.0.4951.41
  • xdg-desktop-portal-kde 5.24.4-1
  • kdialog 21.12.3-1

Any advice is welcome :smiley:

When seeing this, then

  1. Check of the filesystem is needed. ext4 for example:
fsck.ext4 /dev/sdXY
  1. Check the SMART Data.
sudo smartctl --all  /dev/sdXY
1 Like


SMART overall-health self-assessment test result: PASSED

I search the Internet and know that the PASSED means fine.

$ sudo smartctl --all  /dev/sda
smartctl 7.3 2022-02-28 r5338 [x86_64-linux-5.15.32-1-MANJARO] (local build)
Copyright (C) 2002-22, Bruce Allen, Christian Franke,

Model Family:     Hitachi Deskstar 7K1000.B
Device Model:     Hitachi HDT721032SLA360
Serial Number:    STH202MT2YVLJS
LU WWN Device Id: 5 000cca 35fe9c19d
Firmware Version: ST2OA3AA
User Capacity:    320,072,933,376 bytes [320 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    7200 rpm
Device is:        In smartctl database 7.3/5319
ATA Version is:   ATA8-ACS T13/1699-D revision 4
SATA Version is:  SATA 2.6, 3.0 Gb/s
Local Time is:    Wed May  4 21:16:36 2022 CST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

SMART Status not supported: Incomplete response, ATA output registers missing
SMART overall-health self-assessment test result: PASSED
Warning: This result is based on an Attribute check.

General SMART Values:
Offline data collection status:  (0x84) Offline data collection activity
                                        was suspended by an interrupting command from host.
                                        Auto Offline Data Collection: Enabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                        without error or no self-test has ever 
                                        been run.
Total time to complete Offline 
data collection:                ( 4710) seconds.
Offline data collection
capabilities:                    (0x5b) SMART execute Offline immediate.
                                        Auto Offline data collection on/off support.
                                        Suspend Offline collection upon new
                                        Offline surface scan supported.
                                        Self-test supported.
                                        No Conveyance Self-test supported.
                                        Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                                        power-saving mode.
                                        Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                        General Purpose Logging supported.
Short self-test routine 
recommended polling time:        (   1) minutes.
Extended self-test routine
recommended polling time:        (  79) minutes.
SCT capabilities:              (0x003d) SCT Status supported.
                                        SCT Error Recovery Control supported.
                                        SCT Feature Control supported.
                                        SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
  1 Raw_Read_Error_Rate     0x000b   100   100   016    Pre-fail  Always       -       0
  2 Throughput_Performance  0x0005   130   130   054    Pre-fail  Offline      -       123
  3 Spin_Up_Time            0x0007   091   091   024    Pre-fail  Always       -       316 (Average 229)
  4 Start_Stop_Count        0x0012   099   099   000    Old_age   Always       -       6289
  5 Reallocated_Sector_Ct   0x0033   100   100   005    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   125   125   020    Pre-fail  Offline      -       33
  9 Power_On_Hours          0x0012   099   099   000    Old_age   Always       -       9486
 10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       3625
192 Power-Off_Retract_Count 0x0032   095   095   000    Old_age   Always       -       6315
193 Load_Cycle_Count        0x0012   095   095   000    Old_age   Always       -       6315
194 Temperature_Celsius     0x0002   171   171   000    Old_age   Always       -       35 (Min/Max 11/68)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       500

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.


$ sudo fsck /dev/sda -n
fsck from util-linux 2.38
e2fsck 1.46.5 (30-Dec-2021)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks...
fsck.ext2: Bad magic number in super-block while trying to open /dev/sda

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
    e2fsck -b 32768 <device>

/dev/sda contains `DOS/MBR boot sector' data

If it is really ext4, then you set a partition:

sudo fsck /dev/sda1 -n

emm, the HDD is a ntfs filesystem

$ sudo fsck /dev/sda1 -n
[sudo] password for kearney: 
fsck from util-linux 2.38
$ sudo fdisk -l
Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: WDC PC SN730 SDBPNTY-512G-1101          
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 614A2A42-ED51-4C2D-9F82-A1F3105BA07D

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1      2048     534527    532480   260M EFI System
/dev/nvme0n1p2    534528     567295     32768    16M Microsoft reserved
/dev/nvme0n1p3    616448  494850047 494233600 235.7G Linux filesystem
/dev/nvme0n1p4 494850048  746508287 251658240   120G Linux filesystem
/dev/nvme0n1p5 746508288  861851647 115343360    55G Microsoft basic data
/dev/nvme0n1p6 861851648 1000212479 138360832    66G Microsoft basic data

Disk /dev/sda: 298.09 GiB, 320072932352 bytes, 625142446 sectors
Disk model: Storage Device  
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xf1d5f1d5

Device     Boot Start       End   Sectors   Size Id Type
/dev/sda1        2048 625139711 625137664 298.1G  7 HPFS/NTFS/exFAT

Well, then you have to use Windows to check it with chkdsk. Linux does not offer such a tool for NTFS. Only read and write access und the simple tool ntfsfix.

I test ntfsfix. Then I use firefox to pick folder in HDD. firefox still got the problem while chrominum not. So I think there is some problem with firefox cache not the HDD problem. Thanks for your kindly help.

$  sudo ntfsfix /dev/sda1
[sudo] password for kearney: 
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda1 was processed successfully.

Possible… how is the drive mounted?

Normally I mount it like this:

LABEL=data   /media/data   ntfs-3g      defaults,noatime,noauto,windows_names,hide_hid_files,hide_dot_files,big_writes,uid=1000,gid=1000 0 0

Could be a problem with windows_names?

I use Dolphin(File manager) in Plasma. Just clike the icon the mount :smiley:

I am puzzling what it could be…

I would say it is clearly related to the Chinese (?) Symbols and NTFS.

I tried to reproduce it on my ntfs partition:

mkdir "男士穿搭指南:用穿搭。。加分"

and choose it with firefox (which is german). Everything works as expected.

maybe read this:

              This option prevents files, directories and extended attributes to be created with a name not allowed
              by windows, because

                     - it contains some not allowed character,
                     - or the last character is a space or a dot,
                     - or the name is reserved.

              The forbidden characters are the nine characters " * / : < > ? \ | and those whose code is less  than
              0x20,  and  the reserved names are CON, PRN, AUX, NUL, COM1..COM9, LPT1..LPT9, with no suffix or fol‐
              lowed by a dot.

              Existing such files can still be read (and renamed).
man ntfs-3g

yes. Not the Chinese encod problem. I use the HDD a long time. This error info just happen after I delete the folder and its files in qBittorrent. But the error info not happen in Chrominum or kdialog. So I think the firefox choose folder not use kdialog. Though firefox and Chrominum both use gtk3 as depends.

I think remove firefox totally(cache, config and so on) will work. Before I do that thing I think I should check what happen.

Chromium uses KDialog when used on a KDE environment.

agree. test above

I run disk check without repair on Windows 11. It says that there is no error with the HDD. Then I return to firefox. The problem disappear. So there are two possiblility

  1. HDD does exist some problem and the check process think it’s not a big deal not repair it without info.
  2. HDD’s fine. Firefox refresh cache for some reason.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.