Firefox can't see any files in my home directory outside of the Downloads folder

Hi all,

I’m having a weird issue with firefox on Manjaro GNOME. When I go to upload a file to my cloud storage (or any other site that lets you upload a file), the file browser that pops up to select the file can’t see any files in my home directory outside of the Downloads folder. So my current workaround has been copying the file I want to upload to my downloads folder first, and then uploading it, which is obviously just a temporary fix. I’m using Manjaro GNOME with the stock nautilus file browser. I have not changed the permissions on my folders in my home directory, they’re set the way they were upon installation.

What I’ve tried so far:
-Starting firefox in safe mode
-Disabling all my ad & tracker blocking extensions on the sites I try to upload files to
-Disabling enhanced tracking protection on firefox
-Setting all browser associations in .config/mimeapps.list to firefox

All this, and still no dice. Apologies if this is a stupid question or if I’m breaking forum rules. This is my first time posting on these forums, and I’ve only been a Linux user for a few months.

Any help appreciated, thanks :slight_smile:

This sounds like you installed firejail, a security sandbox for your browser that restricts its access to the download folder.

1 Like

I have installed firejail so that I can keep Zoom quarantined, but to my knowledge I’m not running Firefox in firejail. How can I ensure that it isn’t running in firejail?

Hi, welcome to Manjaro. Do you have Firejail active on your Firefox? If you’re unsure, you can type

firejail --list

in a terminal while Firefox is running. If something similar to the following is displayed (where $PID is the process id - some number - and $USER is your username):

$PID:$USER::/usr/bin/firejail /usr/bin/firefox

then you have Firejail configured for Firefox. This sandboxes Firefox, only allowing it to see certain directories; $HOME/Downloads being one of them. You can either add the directories you wish to be accessed to your Firejail profile for Firefox, or you could run Firefox without Firejail.

1 Like

Ah, you beat me to it - my slow typing :wink:

1 Like

Oh my god you’re completely right, it’s running in firejail. I didn’t realize that firejail automatically sandboxed applications, I was under the assumption that it only sandboxed applications that you explicitly told it to. It appears that I was wrong lol. I’m guessing I can disable firejail for firefox in the firejail config wizard?

Best check their documentation at or check the config wizard that comes with it.
Still, firejail’s main job is to sandbox browser attacks, so disabling that feature defeats, in my opinion, its purpose. However, you can also allow other folders, if that would solve it for you.

1 Like

You can delete the firefox entry in


Please note the path very carefully: the /local/ part is very important! This will delete the link Firejail has created for running the Firefox program. You will need elevated privileges (e.g. sudo) for manipulating entries in /usr/local/bin; it is also advisable to backup the file being deleted before carrying this out.

Thank you to both of you for your help, I appreciate the quick reply and the warm welcome to the Manjaro forums. Never expected to have the issue diagnosed and fixed this quickly, I was prepared to wait multiple days for a reply to my topic.

No problem at all. I agree with @6x12, that disabling Firejail for Firefox (or any browser) does kind of defeat the purpose of having it installed though - perhaps just adding some directories you are likely to want to use to the profile may be a better solution. Another alternative would be to create separate .desktop entries for firefox and firejail firefox - you can then choose when you would prefer more convenience or more security.

1 Like

the arch wiki has a lot of good info about firejail, for future reference.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.