Firefox appears on all workspaces

I’m running an up to date Manjaro stable gnome shell desktop. When I launch Firefox, it appears on all workspaces. On applications like gnome-terminal, when I right-click on the top bar I see window manager options such as “Always on visible workspace”. I’m pretty sure this somehow got enabled for my Firefox window. But Firefox uses it’s own native top bar and I can’t seem to find a way to pull up this menu of window manager options. How can I fix this? Thanks!

While Firefox is the foreground app, press Alt+Space to open the window menu. See Keyboard navigation

1 Like

Thank you so much - that was it!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.