Firefox and thunderbird on cinnamon and dual monitor problems


Mozilla apps seem to have twisted mind on their own for placing new windows in dual monitor setup. For example they follow mouse cursor when opening new windows instead of sticking to one monitor. If you move your mouse in a split second when opening the app you are in for a surprise… There is another annoying behavior when computer wakes from sleep and mozilla apps always end up on secondary monitor.

Is there any way to force this apps to stick to selected monitor?


Been a while since I had a dual head setup.

As I recall it - you often have the choice of selecting a primary display in display settings.

When your apps jump to what you consider the secondary display it is most likely either the first detected or it is defined as primary.

“Primary display” is properly set as primary AND display no.1 in display settings, no problem here. Off course one of the displays will always be detected first but this should not affect application behavior and afaik mozilla apps are the only ones behaving like this.

I forgot to mention earlier but this switch to secondary monitor also happens after display sleep when, I believe, displays are not being detected again.

@linux-aarhus is correct, go to System Settings > Windows > Behavior
From there you can command where windows go when opening. Note: Chromium/Chrome have a mind of their own.

My settings are like this. Doesn’t matter which one I choose instead of Automatic, firefox seems to always follow the cursor and change to secondary screen after sleep. No problems with chrome. Or any other application.

Under Location of newly opened Windows, change the selection to something else, like center.

Like I said, all options work exactly the same for firefox - firefox follows cursor. The only slight exception is Manual where I need to confirm window placement with click.

Are you running Wayland?

no, cinnamon on wayland is far from stable…


it’s firefox, no doubt anymore

Devilspie2 does help when opening new firefox window so I can force it to always open on the same monitor. Sadly firefox will still migrate to secondary monitor after sleep. Shame on you mozilla.

Bugs won’t get fixed if they don’t get reported.