Firefox and Layouts Switcher bug

There is a bug in gnome Layouts switcher that prevents Gnome native Firefox theme from being disabled. Toggling the option off, exiting and re-entering the app shows that it has been toggled back on again.

Is your system updated? Was fixed 23 days ago

I updated just three days ago.

I have a second device running Manjaro and I have managed to replicate it on that one. Definitely not an isolated issue.
It appears that gnome native Firefox theme can only be effectively toggled on once. Toggling it on the first time changes Firefox’s theme to gnome, as one would expect. Toggling it off reverts Firefox back to its original theme, but the button in layouts switcher becomes “stuck” to the on position. Toggling it off, then back on again without exiting the app still changes Firefox’s theme.
This appears to have something to do with ~/.mozilla/firefox/<your-profile>/chrome/. inside there is a firefox-gnome-theme file that is a symlink to /usr/share/Firefox-Gnome-Maia/chrome/. the only way to entirely “reset” layout switcher’s behaviour is to delete all the contents inside ~/.mozilla/firefox/<your-profile>/chrome/, then toggle the option off.
perhaps @Chrysostomus might have some insight?

Let me ping @Chrysostomus - and i will also try to replicate the issue later today.


This is just bad coding. Gnome-layout-switcher is pretty hacky. It checks the real status of the affairs only at start-up, and after that the toggle doesn’t reflect the real situation, it just triggers an action whenever you touch it.

There are also some other things like theming that would be nice to update on the fly like theme colors, but it’s going to take some time because I don’t yet know enough gtk3 for it.

It’s not a major issue. Take your time.
Also, what would be the most proper way to “reset” the gnome native firefox theme toggle?

Restart the app, gnome-layout-switcher?

Toggle remains stuck. Even rebooting doesn’t work.

Weird. This has not happened to me. What is needed to reproduce the issue?

Toggling gnome native Firefox theme on, then back off in layouts switcher. You might need to repeat a few times before this bug appears. I have documented layout switcher’s behavior in my second reply.

@bogdancovaciu sorry to disturb you, I noticed you pushed a fix. Please note the issue is not fully resolved. Disabling the toggle is not a persistent setting.

Tested after a clean install of Manjaro Gnome fully updated (yesterday) on an Intel based HP Spectre laptop.

To reproduce:

  1. Open Firefox, confirm theme is Gnome. Confirm also, enabling other themes has no effect.
  2. Close Firefox
  3. Open Layouts, notice toggle for Firefox is enabled. Disable it.
  4. Open Firefox, notice the default-Firefox non-Gnome theme is active. Confirm you can change themes.
  5. Close Firefox.
  6. Reboot
  7. Open Firefox, notice, Gnome theme is back!
  8. Open Layouts, notice the toggle is enabled again

Conclusion: disabling the toggle is not persistent after reboot or logout.

Quite an annoying one. Hopefully it can be solved.

Where did you noticed that? I barely helped a bit with the gnome-layout-switcher 7 months ago, that was my last commit there, all the work is done by @Chrysostomus and with the firefox native theme is almost the same situation. On my installs i can’t reproduce the issue anymore, for a month or so already … I can toggle off, start FF and have the default theme, close FF and toggle on the native theme, open FF and see it applied, close FF and toggle off the theme, start FF and have it normal again …

What iso you installed?

My apologies, I misread post #2 above, you actually quoted @Chrysostomus

I can also open & close Firefox, gnome theme is still disabled. It goes wrong after a reboot: Gnome theme is enabled again.

I installed Manjaro Gnome 21.1.6, 64-bit on a USB stick yesterday and installed it on my Intel based laptop and updated it.

Ok, i could reproduce the issue …
Moreover, if you run from terminal
rm -rf ~/.config/autostart/firefox-theme.desktop
to remove the startup for the theme, strangely enough, even tho the layout switcher is off, after reboot it toggles back on in layout switcher, but not loading the theme actually …
Also, strangely enough, if i run:
pacman -F firefox-theme.desktop
i get

community/manjaro-gnome-settings-dev 20210129-1

so the file belongs to manjaro-gnome-settings-dev but not to manjaro-gnome-settings that is installed by default

Will try to discuss this with Matty.

1 Like

I hope I have not missed something, but is there now at least some manual way, apart from the layout app, to get rid of the gnome theme of firefox?
The fix suggested in Disable firefox gnome native theme does not work, cause the according path “~/.mozilla/firefox//chrome/” does not exist on my install, there is no folder for my or any profile in the folder ~/.mozilla/firefox/.
And I really do need a fix, cause with this theme my mails for work get displayed as white text on white background. And that problem only shows up in firefox with the gnome theming.

Also for me, the layout app straight out crashes whenever I turn the switch of the firefox gnome theming.

I have the same question as @LiFo
It seems the toggle in Layouts now is working AND is persistent.

But it is not something I can change in my post-install script via gsettings or dconf. How can we disable gnome theme automatically/scripted?

@LiFo this should do the trick: sudo pacman -Rsn --noconfirm firefox-gnome-theme-adwaita
I had already disabled it with the toggle, then uninstalled the package. I have not tested simply uninstalling the package but I suppose that has to work as expected.

My remaining question: Will an update of Gnome automatically reinstall this package?
I can block it via /etc/pacman.conf, but if the update of the system is done via pamac (GUI)?