FireFox 98, Intel HD GPU, hardware decoding works?

In the past, I could enable YouTube acceleration on Linux FireFox (intel_gpu_top shows video percentage higher than 0), but in a new installation of Manjaro Gnome, even though I followed the Arch FireFox video acceleration guide, I could not make it work. YouTube vp9 video is playing fine, but on CPU (intel_gpu_top video = 0). Did I do something wrong, or is this a bug of FireFox 98?

Video acceleration works on mpv (for mp4, because I don’t have a local vp9 video).

1 Like

Bug of firefox 98. From Firefox - ArchWiki

Note: As of Firefox 98, VA-API is blocked by RDD sandbox, but can be used by setting the environment variable MOZ_DISABLE_RDD_SANDBOX=1 , although this is less secure. [11]

I personally don’t suggest to disable sandbox as this is a very serious security risk and even more so if you are using a “web browser”. From Firefox - ArchWiki

As a last resort, the content process sandbox can be disabled. However, this is a serious security risk and disables protection against attackers. It is recommended to leave the sandbox settings as default [18].


Here’s what you can do for now:

  • Disable HW on firefox tiil the issue is fixed (Don’t downgrade firefox!)
  • Switch to Chromium as I have done.

No, the thing is that I have tried those dangerous disabling RDD or something, and I still could not get the intel_gpu_top show bigger than 0% for video. So, my question is if anyone, who is using FF98 and Intel HD GPU, has successfully enabled YouTube video acceleration.

If you are okay with disabling sandbox then try launching firefox with this command. This should be enough to enable HW on FF98 given that it was working normally in previous versions.

export MOZ_DISABLE_RDD_SANDBOX=1 && firefox

This works for me as well.

However, you also have to use the intel-media-driver instead of the modesetting xf86-intel one. The latter one is too old and unsupported.
In about:support you should see somewhere something about FEATURE_FAILURE_DDX.

I saw there is a new Firefox version 98.0.1-1, is this Sandbox/Video bug fixed under the new release?

Im still waiting to upgrade from 97.0.2-1 :face_with_thermometer:

yes it is fixed

1 Like

Thanks for the quick response… i don’t wanted to use this workarounds… thats why i was waiting.

Edit: Awesome false information…

What do you mean, the page must contain “FEATURE_FAILURE_DDX” if I am using the correct driver? Because I do not see it (searched, no match).

No, it does not work in 98.0.1-1.

The only thing that worked is

export MOZ_DISABLE_RDD_SANDBOX=1 && firefox

If I started FireFox that way, I could see the “Video” percentage becoming more than 0%.

1 Like

This new version only removes Yandex and mail.ru from search providers.
Firefox 98.0.1, See All New Features, Updates and Fixes

1 Like

On Windows, I have seen “New updates” nagging pop-up for days, and that was all the change? Damn, this is stupid. Yeah, war is a bad thing, but are we going to do this from now on? Whenever a war happens, we are going to remove everything from the country from the society and the Internet? I will see if we will do the same thing to Chinese things when China invades Taiwan.