Firefox-98.0-1 seems broken

I am unable to bring up firefox 98 with Plasma or Qtile (both x11) on a 8GB RPI4. No significant error messages, just the usual DRM complaint. Sometimes a widow would open but it only displayed a titlebar and the window contents were just a copy of my desktop wallpaper.

I tried renaming ~/.mozilla but that did not help. I rolled back to firefox-97.0.2-1 but unfortunately, 98 touched files so a new profile was required, so now using a fresh ~/.mozilla.

It seems to be working on XFCE.

Hmm. Well that is good news, but now more testing for me.

Maybe not it is upgrading right now.

Yep it is broke on my XFCE also. I get the same blank window as you.

Well then that is bad news, but glad I don’t have some other wonky issue that caused it.

With ssh opening it I get more output.

[ray@pi4 ~]$ firefox
Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: X error, error_code=1, request_code=155, minor_code=1 (t=1.59671) [GFX1-]: glxtest: X error, error_code=1, request_code=155, minor_code=1
Crash Annotation GraphicsCriticalError: |[0][GFX1-]: glxtest: X error, error_code=1, request_code=155, minor_code=1 (t=1.59671) |[1][GFX1-]: glxtest: process failed (exited with status 1) (t=1.59684) [GFX1-]: glxtest: process failed (exited with status 1)

Those are the drm messages I mentioned above. I get them with 97 too, but it works.

Edit: Why the test fails? I have wondered and thought one of these days I would bring it up. Seems it should work on a rpi4 with v3d.

I guess the test might require a particular opengl version. I discovered that alacritty will not run a rpi4 with v3d due to the required level of opengl. But interestingly… it will run on an rpi4 with software rendering. llvmpipe supports a higher version of opengl than does the v3d.

I tried llvmpipe and no go either.

Just a note, 98 is working on x86_64.

1 Like

Dis you check at this following page How to debug Firefox problems - Fedora Project Wiki ?

I’ve found it while reading this :

They give lots of commands to test.

The first one to use may be the following one:

firefox --safe-mode

Hope it helps.

Safe Mode did not seem to have an effect, when I ran firefox --safe-mode.

So I wonder what changed between 97 and 98 for ARM devices?



I messed with this some more today. I have a 32 bit arch-arm install and upgraded firefox to 98.0 and it does what it is supposed to. It appears this is an aarch64 issue. They have the same issue on arch arm also.

I compiled Firefox Nightly today and it has the same issue.

My 32 bit install:

1 Like

Maybe we should keep 97 series for now…

1 Like

At least in Manjaro-Arm Firefox 97.0.2 works. In Ubuntu Repo Firefox 97.0.2 for arm64 doesn’t function fully as WebGL is not enabled and cannot be enabled via “about:config” for whatever reason.

Had the same problem on the Pinephone with Phosh. Downgrading to to firefox 97.0.2-1 worked, only slight annoyance with the new profile being created…

Usually it tells you specifically why it’s disabled.

Weird that they have let this go on for 12 days. Looks like the only one doing any work trying to find the issue is the guy who reported it.

@Strit bird dogging: