Firefox 92.0 doesn't play audio (both with pulseaudio or pipewire)


After getting the last (92.0) Firefox I have got a problem on playing YouTube video - loading bar is moving, but video can not be played (timer sticks to zero). Other apps (Zoom, Chromium,…) haven’t got the problem.

The issue doesn’t depend on a device used to playback, be it BT one jr SPDIF output.

Any ideas to resolve?

(KDE DE is in use, the system is up to date)

Please note:

$ pipewire --version
Compiled with libpipewire 0.3.35
Linked with libpipewire 0.3.35

$ pulseaudio --version
pulseaudio 15.0

Therefore, disable PipeWire and enable PulseAudio and try again.


1 Like

The aim is to find a problem in my system: as far as there are no massive “me too”, I guess, the problem exists.

With further thinking I have recognized your suggestion has got more value rather than I was guessing at first. I have replaced pipewire with pulseaudio, and Firefox still is not able to play back. So with your help I know now it is the Firefox who is responsible for the problem :slight_smile:

1 Like

Have you tried the Firefox common audio and video issues yet?

(One of them is Install PulseAudio so you can skip that already)


1 Like

Have tried without success. And yes, after replacing pipewire with pulseaudio I have looked at processes and tried Chromium and Zoom - they do work as expected (as well as pavucontrol, BT and so on).

I have even tried to temporary rename ~/.mozilla.

1 Like

As you never provided an inxi --admin --verbosity=7 --filter --no-host --width, we’re not sure which DE you’re using but If you’re on KDE, can you:


1 Like

Have looked at the settings - Firefox is not muted. And also have installed and tried under Gnome, and the problem still exists. That is it isn’t KDE-related.

1 Like

And at last I have tried firefox 91.0.2 (from packages cache) - it does work. So the problem is related 92 version.

1 Like
Still not resolved in Arch.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Update just got pushed to Firefox: Firefox 92.0.1, See All New Features, Updates and Fixes

Should fix this issue.


Great, thanks for the good news!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.