Firefox 88 glitches with hw acceleration on Intel i915 graphics

After updating Firefox to 88.0-0.1 on xfce stable 20.Apr.2021 I noticed some glitches in colour rendering - disabling both automatic performance optimization and hardware acceleration fixes that. But I don’t consider this as a real solution. Should I check mozilla’s buglist and report there, if nobody did it before? Please, advise which of the following data to include. Thanks a lot.

Sample: ff88-hw-accel-bg-fill-03 ff88-hw-accel-bg-fill-02 ff88-hw-accel-bg-fill-01 (Address bar highlighting)
Issues like this and similiar made websites with coloured tables e.g. unreadable.

$ inxi -Fxzc0
  Kernel: 5.11.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: Xfce 4.16.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASRock model: Q1900B-ITX serial: <filter> 
  UEFI-[Legacy]: American Megatrends v: P2.10 date: 03/01/2018 
  Info: Quad Core model: Intel Celeron J1900 bits: 64 type: MCP 
  arch: Silvermont rev: 8 cache: L2: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16006 
  Speed: 2175 MHz min/max: 1333/2416 MHz Core speeds (MHz): 1: 2175 2: 1346 
  3: 1333 4: 1334 
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
  vendor: ASRock driver: i915 v: kernel bus-ID: 00:02.0 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 21.0.2 
  direct render: Yes 
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
  vendor: ASRock driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
  Sound Server-1: ALSA v: k5.11.14-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.25 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel port: e000 bus-ID: 02:00.0 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 374.39 GiB used: 241.15 GiB (64.4%) 
  ID-1: /dev/sda model: SSD25D120G-MBES size: 111.79 GiB 
  ID-2: /dev/sdb type: USB vendor: Generic model: STORAGE DEVICE 
  size: 29.72 GiB 
  ID-3: /dev/sdc type: USB vendor: SanDisk model: Ultra Luxe 
  size: 232.88 GiB 
  ID-1: / size: 29.72 GiB used: 19.24 GiB (64.7%) fs: btrfs dev: /dev/sdb1 
  ID-2: /home size: 29.72 GiB used: 19.24 GiB (64.7%) fs: btrfs 
  dev: /dev/sdb1 
  Alert: No swap data was found. 
  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 243 Uptime: 42m Memory: 7.49 GiB used: 1.68 GiB (22.4%) 
  Init: systemd Compilers: gcc: 10.2.0 Packages: 1595 Shell: Bash v: 5.1.0 
  inxi: 3.3.04

I’m also getting the same since a recent update. Intel graphics card and Firefox 88:

$ firefox --version
Mozilla Firefox 88.0


$ inxi -G
Graphics:  Device-1: Intel Iris Plus Graphics G7 driver: i915 v: kernel 
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.11 driver: loaded: intel resolution: 1600x900~60Hz 
           OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) v: 4.6 Mesa 21.0.3

If you previously enabled hardware acceleration yourself, make sure to reset what you have done to start clean as Firefox changed many things regarding that and it creates issues when some previously needed parameters are enabled.

  • Remove all environment variables you added for Firefox hardware acceleration
  • Revert all parameters you changed to default in about:config configuration page

Simple solution is to use the ‘Repair Firefox functionality’ (go to about:support page in Firefox, and click the button), but that means you will have to reinstall your Firefox extension and themes (but it will keep all your bookmarks, passwords, things like that). Not a big deal in my opinion to start fresh with new default parameters.

The glitchy rendering persists - I did try the ‘Repair Firefox’ (that moved my actual profile to a new desktop folder and created a fresh profile), but unfortunately this did not change the glitchy behaviour of (background / fill) colour rendering.
A few more details:

  • When hardware acceleration is enabled and I run firefox from the terminal, I get this message after closing firefox (race condition?) - it does not happen with hardware acceleration disabled:
    ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
  • in about:support the graphics driver is named “mesa/i965”, not i915
  • for testing I changed my BIOS shared memory settings from 256 to 512MB and ‘automatic’ - no change of the described issue.

The ‘automatic performance setting’ and hardware acceleration are enabled by default - what I did was disabling them when I had found a hint to do that in the other (now closed) FF88 (on testing) graphics thread here.

As a kind of last resort I may run a different distro on this machine with the same Firefox to check whether the glitches that I observe depend on the build/environment or on Firefox in relation to the hardware. In mozilla’s bugreports I didn’t find anything about it so far.

Any further help or advise very welcome!
Thanks and regards

You can also try FF 89 beta and FF 90 nightly to check of there are any differences.
I have hw acceleration on, i915 no glitches with FF nightly.

Unfortunately my issues persist as described (diagonal ‘stairs’ in small coloured rectangles)

  • with Firefox Developer Edition 89.0b4-1 community repository,
  • with Firefox nightly firefox-90.0a1.en-US.linux-x86_64 mozilla binary.

The issue did not occur

  • with mozilla Firefox 88.0 binary on debian live media
    Linux debian 4.19.0-16-amd64 #1 SMP Debian 4.19.181-1 (2021-03-19) x86_64 GNU/Linux```

(I did not install debian and tried a recent kernel, though.)

  • on Manjaro if bootet with LTE kernel 5.4
    Linux manjaro 5.4.114-1-MANJARO #1 SMP PREEMPT Wed Apr 21 14:34:53 UTC 2021 x86_64 GNU/Linux```

Since I’m rather a user than expert, I can only suspect that i915 is rather a low-budget graphics-controller, the ‘hardware acceleration’ happens in software, and FF 88.0 moved to a function that changed with newer kernels …
Well - I do mostly read text or view stills on websites, and even with hw acceleration disabled I can watch a 720p TV stream.

Anyway, there seems to be a non-trivial mismatch between my J1900 on ASRock Q1900B-ITX with i915, kernel 5.12 (same as 5.11 before) and FF 88.0+ — if that could be fixed, I’d really appreciate it.

Many thanks

Yep seems like a driver issue.

since I have the same graphics card - and no issues at all …

I’d recommend a more radical (but reversible) approach.

kill the browser, shut all instances down

move your current profile to some other location.
copy it
and then remove (delete) the original …

the point being:
… start the browser with no ~/.mozilla directory present …

start the browser again - it will create a fresh profile in which you can later re-import your passwords and bookmarks and such

I very much doubt that.
It may be “low budget”
but it does provide HW accel - not blanket for all and everything, but for certain file types/codecs

I intentionally disabled my (also available) radeon card and solely use the integrated i915 for ease of use and much lower power consumption.
It is perfectly adequate for … any videos …

It was indeed getting hot and slow and rendering was in software before the modifications (see arch wiki).

I made modifications myself to enable HW acceleration and use it for certain file types and even force the use of certain codecs that are hardware accelerated on this hardware.
(not all codecs are)

I used the information in the Arch Wiki to do that.
It works and continues to work flawlessly.
… just changing one or two settings in the browser’s config wasn’t enough …

I’d need to re-discover that info on the arch wiki - but it is rather easy to be found.

For completeness I did the following tests with original .mozilla folder backed up, then completely removed it each time (except for the beta and alpha that I didn’t repeat).

So it seems to be a driver issue. After all the testing I understand “i915” is a driver for a class of different graphics controllers.
As said, perhaps I can live with hw acceleration disabled on this system rather than I’d roll back and run an older kernel without fixes and updates.

Many thanks to all, D.

Reproducable with FF “recommended performance setting” and hw acceleration enabled:

  • Type some text into address bar and highlight different length parts. ff88-hw-accel-bg-fill-01

System Mini-ITX with Intel Celeron J1900 (no 3rd level cache, L2 2x 1024 KiB) and graphics controller “Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display”, driver i915, on a full-HD TV-set via HDMI (maybe, I should test also with the VGA output - P.S.: yes, same on VGA); @mynewlaptop reported “Device-1: Intel Iris Plus Graphics G7 driver, resolution: 1600x900~60Hz” even higher resolution …

  • Kernel 5.12.0-1 with Firefox 88.0-1 and FF 89.0b4-1 and FF 90.0a1
  • Kernel 5.11.16-2 with Firefox 88.0-1
  • (Kernel 5.11.14-1 with Firefox 88.0-0.1)
  • Kernel 5.10.32-1 LTS with Firefox 88.0-1

Not reproduced - with “hw acceleration” disabled for the above - or:

  • Kernel 5.9.16-1 and Firefox 88.0-1
  • Kernel 5.4.114-1 LTS and Firefox 88.0-1
  • Debian Kernel 4.19.0-16 and Firefox 88.0

and on a laptop - driver “i915”, yet CPU “Intel Core i5-6300U” and graphics “Intel Skylake GT2 [HD Graphics 520]” booted from the same USB media as the mini-ITX before:

  • Kernel 5.12.0-1 with Firefox 88.0-1
  Kernel: 5.12.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: Xfce 4.16.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Dell product: Latitude E5470 v: N/A serial: <filter> 
  Mobo: Dell model: 0VHKV0 v: A00 serial: <filter> UEFI-[Legacy]: Dell 
  v: 1.22.3 date: 02/17/2020 
  Info: Dual Core model: Intel Core i5-6300U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 cache: L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 20004 
  Speed: 800 MHz min/max: 400/3000 MHz Core speeds (MHz): 1: 800 2: 2230 
  3: 966 4: 1629 
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915 
  v: kernel bus-ID: 00:02.0 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.0.3 
  direct render: Yes```

Finally someone with the same problem I have! :crazy_face:

Thought nobody else was using intel graphics these days.

I’m using Manjaro on a recently bought ancient Lenovo Thinkpad 11e and had this issue from the day I started using Firefox on it.

I can confirm that this cannot be fixed by deleting the Firefox profile or disabling hardware acceleration in FF. Been there, done that, nothing changed. Even reinstalled Manjaro and did a parallel installation of Windows 10 and Firefox to “cross check”.

First I blamed it on some kind of hardware defect, but as others browsers and applications work flawlessly (and FF on Windows does so too) I can only attribute it to some problem in either FF for linux and/or the intel driver.

Unfortunately nobody seems to have a fix up to now.

1 Like

After you untick both boxes do you restart Firefox for it to take effect? Apparently disabling hardware acceleration fixes the glitches for Intel.

You are right. Disabling hardware acceleration indeed helps. Seems I never restarted FF after disabling HA. :expressionless:

Now I wonder how much performance degradation I have to expect? Any experience?

It depends on your hardware, try to watch this and play with the various quality available and fullscreen/windowed to see if it is OK for you. It is my reference video I test on every computer I have on hands when it comes to this.

My hardware is, well… old. Celeron N2920, albeit with 8 GB RAM and an SSD (which shouldn’t matter in that respect).

I’m going to test with Youtube when I have a little more time. Thanks for your help!

The performance penalty on that system is way too high. (Or the system is way too old. :sweat_smile:)

I’ll keep hardware acceleration on and just live with the glitches. Maybe someday someone will fix either driver or FF. Things could be way worse. :man_shrugging:

After the latest testing update, this issue got much much worse for me. Funny thing is the glitches disappear when I move the mouse over them.

Using the latest kernel marked as experimental in the Manjaro settings manager seems to fix the problem, as far as I can tell by now.

5.13.0-1-MANJARO #1 SMP PREEMPT Mon May 10 05:20:57 UTC 2021 x86_64 GNU/Linux

Everything else (screen brightness control etc.) seems to be working as well, so I will keep this kernel for now.

Same problem here with Firefox. Changing kernel didn’t work. Disabling hardware acceleration did the trick. :+1:

For me, changing the kernel solved that particular problem, but unfortunately introduced some others (not only graphical glitches, but random lockups when using Firefox in combination with heavy graphical distortions) which I only noticed after a while.

I switched back to 5.12 and will just live with the minor glitches present when using this kernel.

I was having the same issue on a Thinkpad X230 (i5-3320, Intel HD 4000, i915 driver) and switching back to kernel 5.4.118-1 solved the issue. looking forward to see this fixed on newer kernels.

1 Like