Firefox 109 update dependency issue

Hi, I’m on ARM unstable branch and I have the following issue:

:: Starting full system upgrade…
resolving dependencies…
warning: cannot resolve “firefox>=109.0”, a dependency of “firefox-i18n-fr”
:: The following package cannot be upgraded due to unresolvable dependencies:
:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency ‘firefox>=109.0’ required by firefox-i18n-fr

I’m not sure how to fix it.

Try sudo pacman-mirrors -f5 && sudo pacman -Syyu.

Maybe your mirror did not complete it’s sync yet.

I’ve tried 5 differents mirror (after updating the list) and I’ve got the same error.
It’s strange because it’s the i18n package that requires the new firefox but it is not available.
If Iremove firefox-i18n-fr package, pacman tells me that everything is up to date.
Even on the archlinux arm mirror, they only have firefox 108 and all i18n packages are labeled 109…

Hm, you are right. Seems Arch Linux ARM did not finish building 109 yet.

The repo is now up-to-date. THX

109 won’t start, mesa need rebuild with llvm update?

1 Like

Thanks. Rebuilt Mesa and uploaded to unstable branch.

whats different between your build & Alarm?

Here is our build so you can compare:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.