Firefox 108 theme is a mess

i will try it someother time. Thank you

Please look into about:config and verify this entry:

layout.css.moz-box-flexbox-emulation.enabled > false

important if you use “aris/CustomCSSforFx/”

which config and where is it ?

1 Like

Upstream is aware of the issue:


In Firefox: type about:config into the search-bar
There will be a warning, accept and type
set it to false, and all tabs are normal size again…

@GaVenga it is already set to false

1 Like

So it will be something different - my FF108 works 100% – no difference to FF107
I do not use any of the buildin themes but:

1 Like

@GaVenga after disabling Gnome native firefox theme , mine works too. but looks like there is a problem known by FireFox as well

1 Like

Thank you so much. This worked for me as well.

1 Like

Thank you man. … What a disaster …

I didn’t find “Layouts” to start the

action, but

sudo pamac remove firefox-gnome-theme-maia

resolved the issue for me.

$ cat /etc/lsb-release

$ pamac info gnome-shell
Name                  : gnome-shell
Version               : 1:43.1+r6+g92e9689a4-1
Description           : Next generation desktop shell
URL                   :
Licenses              : GPL
Repository            : extra

$ pamac info firefox
Name                  : firefox
Version               : 108.0-1
Description           : Standalone web browser from
URL                   :
Licenses              : GPL LGPL MPL
Repository            : extra

OK, but, when I uncheck the “Firefox Gnome Theme” switch and click Apply, it is ON the next time i open the Layout app ! Impossible to deactivate this option, and Firefox is still a mess…

Sorry, I skipped all messages after the 10 first ones, specifically because I see this:


Am I crazy? Or nobody noticed it?

It’s fixed with gnome-layout-switcher 0.8.33-7 coming shortly to the unstable & testing branches.

You can also manually remove the theme:

rm -rf ~/.mozilla/firefox/*.default/chrome/

Then toggle the switch back on and it will install the latest version that fixes the issues.

1 Like

I had the same issue, and the following solved it: sudo pacman -R firefox-gnome-theme-maia

Thanks! still with v. 0.8.33-3 on stable branch.
Removing only the ~/.mozilla/firefox/<default_profile>/chrome/firefox-gnome-theme folder was useful in my case. I can use Firefox again :slightly_smiling_face:
Edit: Firefox personal bar is working after playing with some toolbar settings :joy:

FYI, with the latest version of manjaro-gnome-settings in the testing and unstable branches, it conflicts with and replaces firefox-gnome-theme-maia to make sure no one still has it installed.

After communication with the developer of the theme, new ISO’s will no longer have the Firefox GNOME theme installed by default. Users will need to manually toggle it on to install it. This avoids users having older versions of the theme that are broken to make support easier for the developer.

I rarely use firefox, but it upsets me when something doesn’t work properly. All of written above don’t worked for me, but I found the solve for me. First, in firefox type “about:settings” and click “Refresh firefox…”. After, reinstall “firefox-gnome-theme” using “curl -s -o- | bash”. All about firefox-gnome-theme see on github (find: firefox-gnome-theme). I hope this method will help someone else.

That’s exactly what toggling Firefox GNOME theme on in Layouts does. :wink:

Fine… but for Layouts::Manjaro toggling firefox-gnome-theme dont work. At least for me it’s so :frowning: