Final Fantasy 14 Launcher Won't Open (Steam)

I’ve been on a quest trying to get Manjaro to work on a laptop of mine, and all the issues presiding daily productivity have been addressed, so now it is time to play some games.

I installed Final Fantasy XIV from Steam, thinking proton would be the easiest way to run it (and that is where my copy is). However, I will hit play, and then it will try to launch and then nothing ever comes up; no launcher or anything. I know of the workaround that the new launcher doesn’t work on linux, so you need to adjust some settings in the .config file, however those files haven’t been generated yet (or I don’t know where they are, as the video is on Ubuntu,) as the launcher doesn’t even launch. I don’t really know what you need from me, so I started with a picture of my installed driver and what I know I have, as well as an inxi.

inxi -Fazy                                                                                                                                                                  ✔ 
  Kernel: 5.15.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
  root=UUID=98683eee-40c6-46b7-8a60-eb43f2b1749e rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Micro-Star product: GE75 Raider 10SE v: REV:1.0
  serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Micro-Star model: MS-17E9 v: REV:1.0 serial: <superuser required>
  UEFI: American Megatrends v: E17E9IMS.10D date: 11/17/2020
  ID-1: BAT1 charge: 49.2 Wh (100.0%) condition: 49.2/51.6 Wh (95.5%)
  volts: 12.3 min: 10.9 model: MSI BIF0_9 type: Li-ion serial: N/A
  status: Full
  Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 2 microcode: EA
  cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
  flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 62431
  Speed: 2383 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 2383 2: 4386
  3: 2981 4: 2732 5: 3912 6: 1334 7: 3309 8: 1276 9: 1221 10: 2181 11: 3104
  12: 3107
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Micro-Star MSI
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Micro-Star MSI
  driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
  chip-ID: 10de:1f15 class-ID: 0300
  Device-3: Acer HD Webcam type: USB driver: uvcvideo bus-ID: 1-13:5
  chip-ID: 5986:211c class-ID: 0e02
  Display: x11 server: X.Org compositor: kwin_x11 driver:
  loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa display-ID: :0
  screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 128 size: 381x214mm (15.0x8.4")
  diag: 437mm (17.2")
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.5
  direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
  bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9
  class-ID: 0403
  Sound Server-1: ALSA v: k5.15.2-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: no
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
  bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet
  vendor: Micro-Star MSI driver: alx v: kernel port: 3000 bus-ID: 03:00.0
  chip-ID: 1969:e0b1 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
  bus-ID: 1-14:6 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 1.38 TiB used: 181.21 GiB (12.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
  model: PC SN730 SDBPNTY-512G-1032 size: 476.94 GiB block-size:
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
  serial: <filter> rev: 11111000 temp: 50.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM048-2E7172
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 5400 serial: <filter> rev: 0001 scheme: GPT
  ID-1: / raw-size: 60 GiB size: 58.76 GiB (97.93%) used: 20.77 GiB (35.3%)
  fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 300 MiB size: 296 MiB (98.67%)
  used: 25.7 MiB (8.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 46.0 C pch: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 320 Uptime: 7m wakeups: 1 Memory: 15.45 GiB
  used: 2.84 GiB (18.4%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1311 lib: 380 flatpak: 0 Shell: Zsh v: 5.8
  default: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.09

Let me know if you require anything else, I’m new to linux so I’m not too sure how to go about this, I’ve tried a few things like switching to the 470xx driver, trying different proton versions and such to no avail.
Thank you so much for the help!

Seems like a number of people are having issues after the new update:

Are you also using prime-run so that it uses your dGPU instead of your iGPU?

Search for proton-ge-custom-bin on pamac, install it, once done, head to steam settings and change steam play to proton-ge, with luck you should login without any intervention, but if it launches the launcher & stuck at the cutscene, you have to edit the config files.

Hello, recent developments are as follows;
I installed Proton-GE (the latest one) and switched to it. Only that I noticed after it restarts, the advanced option is unchecked. Not sure what that’s about. I did go into the properties and force it to use proton-GE though.

Still not launching even the launcher. I’m not entire sure what’s meant by Prime-run, tried to do some research with the little time I had and didn’t come up with anything useful. Some insight on that would be greatly appreciated! The whole intent of this is to see if I can do whatever I’d like to on here instead of windows, and I’m sure there’s a way but I just don’t know what it is. Thank you for the help.

I got it to work! The prime-run part did not, unfortunately. I had used that with steam as well as FFXIV, and both times it just never launched. I actually ended up using optimus manager, and since switching to the nvidia card it started right up and I can update now, and with any luck I should be up and playing!

Thank you much!