File picker got worse?

Since last two updates, the file picker got worse.

e.g. Before, when you start typing letter t, it would take you to the first entry starting with that letter (similar to what Thunar does). Now, it opens some search bar at the top, and filters the contents of a folder so all entries with letter t anywhere in the name are shown.

I don’t know which package is responsible for file picker. Is it xdg-desktop-portal?
If so: there are different xdg-desktop-portal-FOO packages — can I install something else from that list that would bring back the old behavior?

Do I need to change something in some config file?

Thank you in advance!

Which ones do you have and what desktop do you use ?

I use i3wm.

I had only xdg-desktop-portal-gtk installed, so I tried to remove it and to install xdg-desktop-portal-lxqt and xdg-desktop-portal-xapp. It didn’t help.

Any other version I should install? Something else to try?

You probably want gtk … but do you have xdg-desktop-portal just ?

Yes, I have that one.

I also had the -gtk version alongside, but I guess that one got updated, which brought this worse version of search/filter.

Please see:

It depends on the file manager you’re using. Either gtk3 or gtk4. Most likely the former.

That’s all you need.

I use Thunar.

As in, I don’t need xdg-desktop-portal along side xdg-desktop-portal-gtk?

xdg-desktop-portal-gtk depends on xdg-desktop-portal. :wink:

❯ pacman -Si xdg-desktop-portal-gtk | grep Depends
Depends On      : gsettings-desktop-schemas  gtk3  xdg-desktop-portal

Ah, you were faster than my attempt to edit my comment :slight_smile:

So, is there something I could do to bring back the old behavior?
I cannot be the only one who noticed this change in recent updates, and who wants the old ways back!?

If there were recent upstream changes with the Gtk 3 FileChooser and/or XDG Desktop Portal, then no. That’s the way it is.

I honestly don’t know what changed. I use GNOME which uses the Gtk 4 version of the FileChooser. It works fine for me. I have Manjaro Xfce in a VM, however I don’t know what I should look for.

That may be, but until very recently at least a number of ISOs shipped with just the backend, and not portal itself. I certainly had to install xdg-desktop-portal myself on the last install.

As to the thread query - I am still trying to gather whether the portal is working or not.

@narimiran do you still get a portal file picker, it just behaves a little differently?

(For some explanation… the deps were changed/implemented a few months back: 5.27.8-2: FS#79754 invert deps (9cec60c0) · Commits · Arch Linux / Packaging / Packages / xdg-desktop-portal-kde · GitLab, but until then Manjaro ISO’s only provided, ex, portal-kde, but not portal … no one noticed or fixed it [ well, I did, but no one listens to me :wink: ] , but Arch changing the deps fixed it for manjaro)

  1. In file chooser, open a directory containing some subdirectories (the more the better).
  2. Let’s say there are lots of subdirectories and you don’t want to manually scroll to find subdirectories starting with letter T.
  3. You type t.

4.a. In the old file chooser, that action would still keep all the contents and it would scroll down to the first subdirectory starting with letter T. (e.g. Tail, Tetris, Twins, …)

4.b. In the new file chooser, this brings some pop-up search bar, filters content so that it keeps all subdirectories containing letter T anywhere in their name. (e.g. Atmosphere, Notes, Captain, …)

And only now, after I typed all that, I discovered that in the new file chooser, I can press ctrl+f to bring back the old behavior!
I guess I need to get used to this new workflow, and that’s it.
Let’s call this one solved.

Big thanks to everyone who offered their help!!

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.