FiiO BTA30 Pro - no sound

I have Fiio BTA30 Pro device. It shows in pulseaudio output settings as my other Denon DAC 310. Denon works great.
But!!! I can’t get sound out at all from this Fiio device. Fiio has own standalone bluetooth system. It’s not confugurable from system. It can be config from own application. So no sound from Bluetooth or analog out. I tested all output settings from pulseaudio, but no sound at all from any application.

Maybe something settings is wrong. Can you solve this via remote connection to my system? It’s easiest way to solve this issue.

Have you searched the internet for FiiO BTA30 Pro Linux? You’re not the first person who had the same issue. :wink:

Something quickly, but seems, that it is some kind of compatility issue. Now when I tried again via dac-mode, audio played about 500ms and then disappeared. It is possible, that it works with dac mode, but Bluetooth mode may be more difficult.

What does that mean? Sounds like you need to spend a little more time to research the issue. My guess is no one here has that device as it’s rather niche.

Now it works. Something settings turning on and off in Fiio Control. Shutdowns, restarts, and then. Suddenly. All works. :smiley::+1:


Do you think this will help others in the future? :grin:

That Fiio BTA30 Pro works, it must be turned on before operating system is started. If you turn device on after system is booted, it not work.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.