Ffmpeg: error while loading shared libraries: libSvtAv1Enc.so.0

Hi guys,

when running ffmpeg I’m getting the following error:

ffmpeg: error while loading shared libraries: libSvtAv1Enc.so.0: cannot open shared object file: No such file or directory

Apparently the reason for this is usually a custom ffmpeg-build (e.g. installed via AUR) and can be fixed by rebuilding ffmpeg. However, my ffmpeg is installed from the official repos.

>> pacman -Qo /usr/lib/libSvtAv1Enc.so* 

/usr/lib/libSvtAv1Enc.so ist in svt-av1 1.1.0-1 enthalten
/usr/lib/libSvtAv1Enc.so.1 ist in svt-av1 1.1.0-1 enthalten
/usr/lib/libSvtAv1Enc.so.1.1.0 ist in svt-av1 1.1.0-1 enthalten
>> pacman -Qi ffmpeg svt-av1

Name                     : ffmpeg
Version                  : 2:5.0.1-3
Beschreibung             : Complete solution to record, convert and stream audio and video
Architektur              : x86_64
URL                      : https://ffmpeg.org/
Lizenzen                 : GPL3
Gruppen                  : Nichts
Stellt bereit            : libavcodec.so=59-64  libavdevice.so=59-64  libavfilter.so=8-64  libavformat.so=59-64
                           libavutil.so=57-64  libpostproc.so=56-64  libswresample.so=4-64  libswscale.so=6-64
Hängt ab von             : alsa-lib  aom  bzip2  fontconfig  fribidi  gmp  gnutls  gsm  jack  lame  libass.so=9-64  libavc1394
                           libbluray.so=2-64  libdav1d.so=6-64  libdrm  libfreetype.so=6-64  libiec61883  libmfx  libmodplug
                           libpulse  librav1e.so=0-64  libraw1394  librsvg-2.so=2-64  libsoxr  libssh  libtheora  libva.so=2-64
                           libva-drm.so=2-64  libva-x11.so=2-64  libvdpau  libvidstab.so=1.1-64  libvorbisenc.so=2-64
                           libvorbis.so=0-64  libvpx.so=7-64  libwebp  libx11  libx264.so=164-64  libx265.so=199-64  libxcb
                           libxext  libxml2  libxv  libxvidcore.so=4-64  libzimg.so=2-64  opencore-amr  openjpeg2  opus  sdl2
                           speex  srt  svt-av1  v4l-utils  vmaf  xz  zlib
Optionale Abhängigkeiten : avisynthplus: AviSynthPlus support
                           intel-media-sdk: Intel QuickSync support [Installiert]
                           ladspa: LADSPA filters [Installiert]
                           nvidia-utils: Nvidia NVDEC/NVENC support [Installiert]
Benötigt von             : blender  chromaprint  electron  electron11  electron14  electron17  electron9-bin  ffmpegthumbnailer
                           ffmpegthumbs  firefox  gst-libav  kfilemetadata  mayavi  mencoder  mplayer  mpv  obs-studio  opencv
                           openshot  qt5-webengine  qt6-webengine  shotcut  xine-lib
Optional für             : alsa-plugins  gegl  libde265  mlt  python-matplotlib  vtk  youtube-dl
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 35,23 MiB
Packer                   : Jan Alexander Steffens (heftig) <heftig@archlinux.org>
Erstellt am              : Do 16 Jun 2022 01:13:02
Installiert am           : Fr 22 Jul 2022 09:38:07
Installationsgrund       : Ausdrücklich installiert
Installations-Skript     : Nein
Verifiziert durch        : Signatur

Name                     : svt-av1
Version                  : 1.1.0-1
Beschreibung             : Scalable Video Technology AV1 encoder and decoder
Architektur              : x86_64
URL                      : https://gitlab.com/AOMediaCodec/SVT-AV1
Lizenzen                 : BSD  custom: Alliance for Open Media Patent License 1.0
Gruppen                  : Nichts
Stellt bereit            : Nichts
Hängt ab von             : glibc
Optionale Abhängigkeiten : Nichts
Benötigt von             : ffmpeg  ffmpeg4.4  libavif
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 7,10 MiB
Packer                   : Antonio Rojas <arojas@archlinux.org>
Erstellt am              : So 12 Jun 2022 10:42:56
Installiert am           : Di 19 Jul 2022 14:55:05
Installationsgrund       : Installiert als Abhängigkeit eines anderen Pakets
Installations-Skript     : Nein
Verifiziert durch        : Signatur

Does anyone know how to fix this? Should I just link /usr/lib/libSvtAv1Enc.so to /usr/lib/libSvtAv1Enc.so.0?

Reinstall svt-av1 package and reboot:
pamac install svt-av1

I have already tried that (reinstalling ffmpeg too), it doesn’t work.

The packages looking up to date. Are you sure you using the ffmpeg binary from the repo package?

What is the output of

which ffmpeg 

and can you try start ffmpeg with the full path?

1 Like

Ahhh, it was also installed via anaconda and accessing this instead. For whatever reason removing ffmpeg and svt-av1 didn’t remove the according files in ~/anaconda3/bin, so I had to delete them manually. Now it works, thanks!

The package manager doesn’t remove files that are not part of the package. It will only install and remove files that are included in the specific packages. And of course a system package manager does not touch your Home directory. Files you create in your Home will not remove, no matter what, even if it’s a binary that provides the same function and has the same name.

I mean removing the packages via conda (after removing the pacman-packages) didn’t remove those files.

EDIT: I guess it shouldn’t be like this, but removing conda-ffmpeg with sudo worked now.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.