Fedora not showing up in Manjaro Boot Loader

I have Manjaro, Windows, Linux Mint and Fedora installed. When I boot up the system, the Manjaro Boot Loader only shows Manjaro, Windows and Linux Mint, but not Fedora. I already did sudo update-grub, and it recognized Fedora, but its still not showing up. In the egibootmgr it looks like this:

BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0005,0000,0001,0002,9999
Boot0000* ubuntu
Boot0001* Windows Boot Manager
Boot0002* Internal Hard Disk
Boot0003* Manjaro
Boot0005* Fedora
Boot9999* USB Drive (UEFI)

The asterisk indicates that its active, but its still not showing up? Any advice?
And i assume ubuntu in that case is Linux Mint.

Kind Regards

What is shown by efibootmgr and what is added to grub is two different places.

Booting entries from efi can be done using your systems boot-override key - the key is vendor dependant - where a common key is F12.

If one system consitently is not added to grub - it could be because installation method is different - different as in BIOS vs EFI and the two cannot be combined.

Uncomment GRUB_DISABLE_OS_PROBER=false in /etc/default/grub and

$ sudo update-grub


It’s disabled by default by upstream for security reasons.

GRUB_DISABLE_OS_PROBER=false is already uncommented :frowning_with_open_mouth:

Which means it was enabled by default?

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

The ability to scan for other operatning systems is default disabled and the user must actively enable this functionality.

This is what this setting do - it enables the disable funciton - and yes it looks a bit awkward.

See it as a rehorical question

Should I disable the probe for other systems? yes/true - no/false

Can you boot Fedora from your UEFI firmware?

1 Like

Affirmitive Sir. I guess it’s a good workaround, but is there a way to add it to the Manjaro Boot Menu?

Kind Regards

i think what remains to be seen is whether os-prober can detect your fedora install, so i suggest you manually run os-prober on its own whilst booted in manjaro.

$ sudo os-prober

ideally it should output lines for all OS’ installed and see fedora is within the list