Fcitx5 Korean (Hangul), space is inserted in a wrong position, when typing in gedit

I installed fcitx5 from the official repository, and added Japanese (mozc) and Korean (Hangul) to it. Now, if I try to type Korean in the default text editor (gedit), there seems to be a random problem with the last letter.

If I type “고양이” and press the space bar, sometimes it becomes “고양 이”. That is, it should have been "고양이 ", but the space was inserted before the last letter. It does not happen 100% of the time, but happens often enough so that I could reproduce the problem within a minute.

Is there a solution to this problem?

If it is of any help, here is the content of my ~/.config/fcitx5 : Filebin | 9w4c0r5o7pm2ocwr I wanted to uploaded it here, but it seems that ZIP is not allowed.

I need more testing, but it seems that installing manjaro-asian-input-support-fcitx5 somehow solves the problem.

Checking in to report that I have the same problem, and installing manjaro-asian-input-support-fcitx5 did not make a difference (even after logging out and back in).

Are there any additional steps I can take to get this working?

I don’t see any documentation at the package page https://aur.archlinux.org/packages/fcitx5-input-support, or indeed at its dependency GitHub - fcitx/fcitx5-hangul either.

I don’t remember what else (if any) I did. All I can say is that it has not happened since then. Here are the packages that are installed on my PC:

And settings:



Screen recording:

Thanks for this. Unfortunately, I’m still having the same issue after copying your settings. (The precise behavior is somewhat app-dependent. In gedit, I get the “random” spacing you described, whereas in Kate, I don’t get any spaces at all unless I press space twice.)

Is your physical keyboard a Korean keyboard (with the 한/영 toggle key etc)?

I’m on a 2012 Macbook Pro with a physical US keyboard.

I will keep searching on Korean message boards and report back here if I find anything.

And when I have time, I’m going to try to learn to install vanilla Arch and see if I can replicate the same problem.

It is a laptop so, it does not have a dedicated Korean/English key, but just right-alt.

If you just want Korean input, use iBus instead. It is easier to set up than fcitx (all you have to do is install ibus and ibus-hangul) under Gnome. I only use Fcitx because of Japanese input (Mozc).

Switching to ibus ended up being the solution for me. For some reason I haven’t been able to change the keyboard shortcut for toggling Hangul mode from the default Shift+Space to my preferred Super+Space. In ibus-setup-hangul, if I try to add a toggle key and press Super+Space, it only picks up the space key.

I had asked about using Super+Space with FCITX and I am not sure if it is the same problem but Gnome by default uses that combination for a predefined thing. Maybe going to keyboard shortcut settings and removing Super+Space will allow you to use it for other things.