Fancontrol service doesn't start

Hello everyone,

I have been trying to install Manjaro in a dual boot scenario, and I was trying to set up fancontrol and fancontrol GUI. I have previously, around a year ago, been able to get it to work on Ubuntu. My system is built with an ASUS PRIME B450 PLUS, and I know that the sensor inside it isn’t normally supported, so just like I did on Ubuntu, though through AUR this time, I installed the IT87 sensor, did modprobe, it found it, and then I followed the instructions from the Arch wiki. I ran sudo sensors-detect, it found them, I ran sudo pwmconfig, everything worked perfectly, it found all fans, I saved the configuration file, then I installed Fancontrol GUI, set the fancurves, and started the service.

However, all my fans continued to spin at 100%. I looked around the internet for a solution and I couldn’t find one, but I ran “systemctl status fancontrol”, and it told me the service hadn’t started with an error along the lines of “Couldn’t start PWM for hwmon3/pwm1”. I had the actual terminal output saved to a document, but it was late, I was growing increasingly frustrated and I booted back into Windows and deleted the Manjaro partition, so if needed I can go through the entire process again and provide an exact terminal output, because I really, really want to properly start running Manjaro and it would be a shame for me to give up like this.

I have no idea what the issue could be however. I’ve entertained the thought that it might be because of my hardware setup - I have four DC fans installed in my case, and all of them are connected to an ARGB LED and Fan Splitter that my case came with, and then that fan splitter is connected to the motherboard with a PWM cable. The chassis fans in question are set in BIOS as DC fans, but I’ve had a few issues over on the Windows side with ASUS AI Suite not properly recognizing them. But since Fancontrol worked when I last tried it on Ubuntu 20.04 I don’t know if this can be a hardware issue.

Any help would be greatly appreciated, and if more information is needed, I can try to reinstall it and provide it.

Did you have a look at this note on Arch wiki ?

Note: Some users may experience issues when using /sys/class/hwmon/ paths for their configuration file. hwmon class device symlinks point to the absolute paths, and are used to group all of the hwmon sensors together into one folder for easier access. Sometimes, the order of the hwmon devices change from a reboot, causing fancontrol to stop working. See #Device paths have changed in /etc/fancontrol for more information on how to fix this.

I had this issue, everything was fine until you restart my system, and the service did not want to start.

1 Like

I don’t know, for me fan control doesn’t work from the moment I set it up, without any reboot.

When running pwmconfig, each fan is tested in order to find out its max and min speed, so you can hear them from min to max.
Do they spin at different levels at this step ?

At this stage, it asks you some questions related to the correlation between your fans and the pwm cycles.

I would try to do it like that first to see if everything if ok before to play with the gui.

1 Like

Everything went well there. Pwmconfig tested each fan, found the correlation, spun them at different levels, and everything went well there.

After that was over, it gave me several different options, and I chose the option to save it to the config file and to exit.

After that, I opened Fancontrol GUI, set up the curves, started the service from within the app and applied the fan curves, but nothing changed, instead the fans kept spinning at 100%. The application itself gave me no clue as to what was wrong, but checking on fancontrol service in the terminal showed me that the service didn’t in fact manage to start. It fails with that error “couldn’t start PWM”.

I have no idea what I did differently I’m afraid, but I reinstalled Manjaro, tried everything again, and now fancontrol works without any issues.