Fan not turning on (Lenovo Yoga L390 )


since a few days my fan on my Lenovo Notebook is not turning on the fan anymore even on high heat! ( e.g. when running a 4k video).

The sensors -u gives the following output (when 4k video is playing):

Adapter: Virtual device
  temp1_input: 74.000

Adapter: ISA adapter
  in0_input: 0.000
  in0_min: 0.000
  in0_max: 0.000
  curr1_input: 3.000
  curr1_max: 0.000

Adapter: PCI adapter
  temp1_input: 36.850
  temp1_max: 84.850
  temp1_min: -273.150
  temp1_crit: 84.850
  temp1_alarm: 0.000
Sensor 1:
  temp2_input: 36.850
  temp2_max: 65261.850
  temp2_min: -273.150
Sensor 2:
  temp3_input: 35.850
  temp3_max: 65261.850
  temp3_min: -273.150

Adapter: ISA adapter
  in0_input: 5.000
  in0_min: 5.000
  in0_max: 5.000
  curr1_input: 3.000
  curr1_max: 3.000

Adapter: ISA adapter
  fan1_input: 0.000
  temp1_input: -127.000
  temp2_input: 1.000
  temp3_input: 4.000
  temp4_input: 0.000
ERROR: Can't get value of subfeature temp5_input: Can't read
ERROR: Can't get value of subfeature temp6_input: Can't read
  temp7_input: 0.000
  temp8_input: 0.000

Adapter: ISA adapter
Package id 0:
  temp1_input: 90.000
  temp1_max: 100.000
  temp1_crit: 100.000
  temp1_crit_alarm: 0.000
Core 0:
  temp2_input: 90.000
  temp2_max: 100.000
  temp2_crit: 100.000
  temp2_crit_alarm: 0.000
Core 1:
  temp3_input: 87.000
  temp3_max: 100.000
  temp3_crit: 100.000
  temp3_crit_alarm: 0.000
Core 2:
  temp4_input: 90.000
  temp4_max: 100.000
  temp4_crit: 100.000
  temp4_crit_alarm: 0.000
Core 3:
  temp5_input: 89.000
  temp5_max: 100.000
  temp5_crit: 100.000
  temp5_crit_alarm: 0.000

Adapter: ACPI interface
  in0_input: 11.372

The fan is not broken, the BIOS starts it up when turning on the computer. Maybe this came after an update?

My computer stats :

> inxi --admin --verbosity=7 --filter --no-host --width 

  Kernel: 5.15.138-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=f91d5c3c-771a-42ad-bc25-a42929a9fec9 rw quiet splash apparmor=1
    security=apparmor resume=UUID=e38abb1d-2937-46c5-800a-994a5aa81cf5
    udev.log_priority=3 ipv6.disable=1
  Desktop: GNOME v: 45.1 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 45.0.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: LENOVO product: 20NT001KGE v: ThinkPad L390 Yoga
    serial: <superuser required> Chassis: type: 31 serial: <superuser required>
  Mobo: LENOVO model: 20NT001KGE v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: R10ET33W (1.18 )
    date: 05/24/2019
  ID-1: BAT0 charge: 27.9 Wh (80.9%) condition: 34.5/45.0 Wh (76.7%)
    power: 7.4 W volts: 11.8 min: 11.1 model: LGC 01AV481 type: Li-poly
    serial: <filter> status: discharging cycles: 402
  System RAM: total: 16 GiB note: est. available: 15.27 GiB
    used: 3.57 GiB (23.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-8565U bits: 64 type: MT MCP arch: Whiskey Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x8E (142) stepping: 0xB (11) microcode: 0xF4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1298 high: 2483 min/max: 400/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 900 2: 900 3: 2379 4: 2483
    5: 900 6: 900 7: 968 8: 957 bogomips: 32012
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp
    rep_good sdbg sep sgx smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:3ea0 class-ID: 0300
  Device-2: Bison SunplusIT Integrated Camera driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:2 chip-ID: 5986:2113
    class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x075f built: 2017 res: 1920x1080
    hz: 60 dpi: 166 gamma: 1.2 size: 294x165mm (11.57x6.5") diag: 337mm (13.3")
    ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast gbm: drv: iris surfaceless: drv: iris x11: drv: iris
    inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 620 (WHL GT2)
    device-ID: 8086:3ea0 memory: 14.91 GiB unified: yes
  Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403
  API: ALSA v: k5.15.138-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.84 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Intel Ethernet I219-V vendor: Lenovo driver: N/A modules: e1000e
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15be class-ID: 0200
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter
    driver: rtl8188eu type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 1-3:5 chip-ID: 0bda:8179 class-ID: 0000 serial: <filter>
  IF: enp0s20f0u3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 931.51 GiB used: 413.33 GiB (44.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 1B2QEXM7 temp: 36.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 914.42 GiB size: 898.99 GiB (98.31%)
    used: 413.33 GiB (46.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: f91d5c3c-771a-42ad-bc25-a42929a9fec9
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: NO_LABEL uuid: C036-B6F4
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 16.79 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3 label: swap
    uuid: e38abb1d-2937-46c5-800a-994a5aa81cf5
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-3:5 info: Realtek RTL8188EUS 802.11n Wireless Network Adapter
    type: Network driver: rtl8188eu interfaces: 1 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 500mA
    chip-ID: 0bda:8179 class-ID: 0000 serial: <filter>
  Device-2: 1-5:2 info: Bison SunplusIT Integrated Camera type: video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1
    mode: 2.0 power: 500mA chip-ID: 5986:2113 class-ID: 0e02
  Device-3: 1-6:3 info: Wacom Pen and multitouch sensor type: HID
    driver: usbhid,wacom interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 400mA chip-ID: 056a:5158 class-ID: 0300
  Device-4: 1-7:9 info: Synaptics Metallica MOH Touch Fingerprint Reader
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 06cb:00a2 class-ID: ff00 serial: <filter>
  Hub-2: 2-0:1 info: super-speed hub ports: 6 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 0
  Processes: 279 Uptime: 3h 28m wakeups: 1 Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1951 pm: pacman pkgs: 1936 libs: 483 tools: gnome-software,pamac
  pm: flatpak pkgs: 0 pm: snap pkgs: 15 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.31

Hope you can help me out

Maybe take a look here: Fan speed control - ArchWiki

Maybe try another Kernel (6.1, 6.6) ?

I tried a new kernel (6.1 and 6.6.) that sadly didnt help.

Also the provided article is also not of help. I tried installing thinkfan, but it did not work. I guess the reason is that “thinkpad-isa-0000” outputs wrong values? Can it be that my temperature sensors are broken?

Adapter: ISA adapter
fan1:           0 RPM
fan2:           0 RPM
CPU:         -127.0°C  
GPU:           +1.0°C  
temp3:         +4.0°C  
temp4:        +53.0°C  
temp5:            N/A  
temp6:            N/A  
temp7:        +48.0°C  
temp8:        +66.0°C  

Coretemp-isa-0000 puts out more reasonable cpu temps:

Adapter: ISA adapter
Package id 0:  +84.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +84.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +83.0°C  (high = +100.0°C, crit = +100.0°C)
Core 2:        +83.0°C  (high = +100.0°C, crit = +100.0°C)
Core 3:        +83.0°C  (high = +100.0°C, crit = +100.0°C)

Can someone explain to me what exactly coretemp-isa-0000 is and how i can maybe use that as a temp reference to get my fans running?