Fan constantly fluctuating between 1600-2100 RPM

Hello, I got very friendly support here last time so I’ll try again.

I have a self-build PC with an AMD Ryzen processor. Problem is that even if idle (or when I am using it for low loads), the fan constantly fluctuates between around 1600 RPM and 2100 RPM. I got these numbers using the sensors command. The processor temperature is around 50 degrees while this is happening.

Therefore I have a constant quieter/louder cycle which is pretty annoying. I’d say the fan is quieter (1600 RPM) for a few seconds and then louder for a few seconds again.

How can I go about debugging this?


All you have to do is following this : Fan speed control - ArchWiki

I personally have fancontrol and fancontrol-gui which give me something like this :

I don’t know what’s you fan characteristics, but 1600 rpm is not slow/quiet (i have 2 Noctua 140mm and 120 mm)

1 Like

Thank you. I read that article yesterday and used pwmconfig to configure my fans. Problem is, that if I run fancontrol now, I get the following output:

Loading configuration from /etc/fancontrol ...

Common settings:

Settings for hwmon2/pwm2:
  Depends on hwmon0/temp2_input
  Controls hwmon2/fan2_input

Device path of hwmon2 has changed
Device name of hwmon2 has changed
Configuration appears to be outdated, please run pwmconfig again

Using fancontrol-gui it also tells me Invalid fan entry: 'hwmon2/pwm2' on startup. I can use it then though. But while using it I noticed that CPUTIN is negative. Here is the full sensors output:

Adapter: PCI adapter
Tctl:         +51.5°C  
Tdie:         +41.5°C  

Adapter: ISA adapter
Vcore:                 720.00 mV (min =  +0.00 V, max =  +1.74 V)
in1:                     1.27 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
AVCC:                    3.39 V  (min =  +2.98 V, max =  +3.63 V)
+3.3V:                   3.39 V  (min =  +2.98 V, max =  +3.63 V)
in4:                     1.86 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:                   824.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:                     1.21 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
3VSB:                    3.46 V  (min =  +2.98 V, max =  +3.63 V)
Vbat:                    3.26 V  (min =  +2.70 V, max =  +3.63 V)
in9:                     0.00 V  (min =  +0.00 V, max =  +0.00 V)
in10:                  936.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in11:                    1.07 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in12:                    1.70 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in13:                  328.00 mV (min =  +0.00 V, max =  +0.00 V)  ALARM
in14:                    1.84 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
fan1:                     0 RPM  (min =    0 RPM)
fan2:                  2132 RPM  (min =    0 RPM)
fan3:                     0 RPM  (min =    0 RPM)
fan4:                     0 RPM  (min =    0 RPM)
fan5:                     0 RPM  (min =    0 RPM)
SYSTIN:                 +31.0°C  (high =  +0.0°C, hyst =  +0.0°C)  ALARM  sensor = thermistor
CPUTIN:                 -62.5°C  (high = +80.0°C, hyst = +75.0°C)  sensor = thermistor
AUXTIN0:                +15.0°C    sensor = thermistor
AUXTIN1:                +29.0°C    sensor = thermistor
AUXTIN2:                +22.0°C    sensor = thermistor
AUXTIN3:                -28.0°C    sensor = thermistor
SMBUSMASTER 0:          +54.0°C  
PCH_CHIP_TEMP:           +0.0°C  
PCH_CPU_TEMP:            +0.0°C  
intrusion0:            ALARM
intrusion1:            ALARM
beep_enable:           disabled

Could this be the problem?
Using fancontrol-gui I can also observe the exact behaviour of the fan. It is suddenly pushed up to around 60%, then slowly declines to around 40-45% and then pushed up to 60 again. The whole process takes a few seconds.

I think you did not read the article correctly

Note: Some users may experience issues when using /sys/class/hwmon/ paths for their configuration file. hwmon class device symlinks points to the absolute paths, and are used to group all of the hwmon sensors together into one folder for easier access. Sometimes, the order of the hwmon devices change from a reboot, causing fancontrol to stop working. Go to #Device Paths have Changed in /etc/fancontrol for more information on how to fix this.

This will fix your issue, the solution they give worked for me. I had the same error message as you after reboot.

1 Like

Rather than depending on software that may/may not work, depending on the actual usability of the Nuvoton drivers…why not just set your curves in your BIOS?

That was my first thought, and then i played with settings in my uefi. But it has some limitations, for me at least, my uefi is old and it does not work well for this purpose.

it’s more relevant to change your fan curve, if needed, without having to restart your computer.
You only have to modify a config file or in the gui and restart the service.
It’s not, set your curve once and then forget it forever. For instance, sometimes i switch my fans off so my heatsink is in passive mode, but in summer, when it’s very hot, i don’t do that. Same thing when i play etc …i don’t want to restart my computer each time.
I never had any issue with fancontrol.

Hello, thanks for the suggestion. I’ll try that too. After some more tweaking I got fancontrol to work (wanted to upload an image here but I am not allowed to it seems).

The processor is actually way quieter now. I did not really understand what the difference between the different sensors is. I guess the k10temp sensors are somthing AMD-specific and the nct6779 are some other motherboard sensors? I just used k10temp TCtl for now.

I guess the spiking behaviour of the fans was actually not a bug, but this is what the CPU temp also does.
Observing the TCtl sensor from k10temp on my Plasma Widget I see that even if I am doing nothing at all, it spikes up every few seconds from around 40-45 to 50-55. The fans probably just followed that pattern. fancontrol manages to not follow all these micro spikes and stay quite.

The temperature while typing this post and doing nothing else is around 55-60 degrees by the way.

It could also be related to a defective fan or a bad quality one.
Anyway, happy your issue is resolved.
Do not forget to tick the solution box under my second post :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.