'Fallback' font puzzle

After recently doing some reconfig, and blanking out some unwanted fonts from display, I have another issue to fix.

  1. When I select my ‘text’ font as a non-Thai font, the Thai content is rendered very small…

I want to know what font is being used for characters not included, and how can I identify and change THAT backup font?

2024-02-10 15:32:29

I would like this font to be the default fallback whenever Thai turns up:
2024-02-10 15:35:03

The problem pops up with different results in different areas…

I pinned it down to ‘DillenialUPC’ font, which is used by my wife’s company for documents. Is there a way to stop it taking over for anything else?

‘DillenialUPC’ is a Microsoft font.

To see which font is the default font for Thai scripts try, in a terminal:

$ fc-match :lang=th

On my machine, that shows me that the default Thai font is DroidSansThai.ttf: "Droid Sans" "Regular"

To see all the Thai language font files that that are installed on your system, try:

$ fc-list lang=th

The Thai font might be set from your desktop’s font manager. You might set your DE’s font to one of the Noto or Droid family fonts. I know they have Thai support. Some terminal emulators have a ‘Preferences’ option to set the fonts used; urxvt (rxvt-unicode) and xterm set the fonts in ~/.Xresources. Urxvt is the more versatile choice if you use multiple locales.

If you can’t change the default Thai font from the font manager, the application, or from .Xresources, then you have to write or edit some fontconfig files. See the ArchWiki, https://wiki.archlinux.org/title/Font_configuration and https://wiki.archlinux.org/title/Font_configuration/Examples.

1 Like

Brilliant, thank you.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.