Falkon / qtwebengine 100%

I’m not sure if this is a manjaro problem, a falkon one or a qtwebengine one. Or even an interaction between qtwebengine and XFCE.

I run falkon as my primary web browser with about a dozen windows open, each containing at least three tabs. Mostly the windows are minimized. In general this works fine, although a small number of sites will not work properly - or at all.

I’ve recently hit a site - wetransfer - which hangs during loading. The loading never completes and the Stop button fails to stop it. The only way out is to kill the tab.

During the loading the qtwebengine exceeds 100% cpu. After killing the tab the cpu usage remains around 100% - for “ever”. The only way out is to launch the task monitor, find the qtwebengine instance that is causing the over-use, and kill it.

I suspect the primary cause of all this is qtwebengine, though it may be falkon missing a response code from the engine.

I am unsure where the onus lies in fixing this bug as I do not know enough about the manjaro build responsibility and so forth.

Hi @dstiles,

AFAIK this would be a Falcon issue, especially if it works in other browsers. Have you tested with another browser? Perhaps Firefox, since it’s in the repositories.

pamac install firefox

No other browser (about 5 including FF) causes a high cpu rate.

Have you cleared your browser cache/cookies/history and start again?

This has been going on for a few months. I’ve done various things such as clearing cache etc.

Have you also tried with a new session. There is a session manager included in the menu.
Also go over all the Falkon settings.

E.g. wetransfer loads a bit slow on my Falkon instance but not at 100%. However, I don’t have a dozen windows open at the same time.

Which QtWebengine version does your Falkon installation display?
Have you tried to start from terminal?

It isn’t only wetransfer - that’s just the most frequent. It never used to cause a problem until recently - I’ve been using falkon for two or three years now. I’ve never found the quantity of open windows to be a problem with any browser, including falkon.

I’ve been through falkon settings a few times - nothing obvious (there aren’t many anyway).

Starting from terminal makes no difference.

Falkon version 22.04.3
Qt version 5.15.5

Version is up to date.

wetransfer is javascript heavy.
What if you disable javascript in Falkon Preferences > Browsing > Allow JavaScript = off ?
(Note: when off wetransfer will display a banner that you need to enable javascript)

You may try in terminal with JS settings on:

falkon -o wetransfer.com 

Note: From my Falkon usage I can say that websites with video players embedded will turn my CPU usage up to 40-60%. Hardware dependent of course.

I use FF on Plasma and every once in awhile, some website pushes my laptop to it’s limit. I’m sure its some ad that is pushing lousy JS code or is having trouble of an unknown origin. Turning off JS and blocking ads might help, but that causes other problems. My solution is just to exit the browser and let everything calm down.

That is counter-productive. You need javascript enabled before you can access the download panel, which never happens. Certainly there is no download.

I am used to an increase in cpu activity when downloading things. This is a case of abnormal activity and persistence during CONNECTION and beyond cancellation of the CONNECTION, not the DOWNLOAD, which the browser never gets to.

This is NOT a JS problem. Intuition suggests it’s qtwebengine, since only that needs to be killed in order for the problem to go away. It MAY be the interaction between falkon and qtwebengine or possibly a side effect of qtwebengine / XFCE interaction but it seems to be website specific - NOT just wetransfer, that’s just the most frequent and the one I remember.

I agree shutting down all browser windows solves the problem but that is annoying and the easier solution of cancellation via task monitor (or via terminal) is a simpler solution.

Yes it is. Most websites do not function properly when JS is disabled. It was meant for testing purposes only.

While I don’t know your hardware I tend to say it’s purely website specific, maybe combined with recent qt upgrades.

Your best hope probably is that future updates improve the performance of the webengine.

There would be other tests you could do, e.g. try in a new user profile; reinstall related packages.
If nothing works, maybe switch to another browser, as you say they don’t have the problem.

Ah, well. Thanks to all who answered. I’ll just put up with it as falkon is otherwise a reasonable browser with an easy-to-use JS on/off switch. There’s always epiphany-web or firefox for the awkward sites.

FYI, similar recent reports from upstream. Not much response though.

Thanks for the links, raguse. But they refer to KDE not XFCE and the reponses are different. I suspect they are similar in origin, though, and that XFCE just has a more severe reaction.

Falkon is an application developed by KDE and the bug reports refer to Falkon.
Xfce is not a Qt desktop environment, that may complicate it a bit, but shouldn’t make much of a difference with browsers. A GTK native browser might be better in your case.
Btw, I use Falkon along with KDE Plasma.

I too had issues with Falkon. Of all the ALT browsers I have tried including Otter, Midori, and Falkon the one I really like that is QT based is Dooble. It is fairly full featured and in the repo.

Sorry to disappoint - AUR is not the repo but a custom buildscript site

 $ pamac search dooble
dooble-bin                                          2023.04.10-2  AUR 
    Web browser based on QtWebEngine
dooble                                              2022.11.15-1  AUR 
    Web browser based on QtWebEngine

1 Like

Right you are. But just try it.