Fake suspend! Battery drains as usual

Hi. Very new laptop with AMD Ryzen 5 (4000 series) and AMD Radeon graphics. Based on what I’ve read at other forums, I suspect this particular hardware combo might not do suspend in Linux. But let’s see…

Hibernate works, but I’m a big fan of suspend, which does not work. The screen goes black after selecting suspend from log-out menu or after pushing the power button, or even after entering “systemctl suspend” in terminal.

However, the power button light stays on, I can hear the fan, and I can even toggle through the keyboard backlight brightness options while the laptop is allegedly suspended.

I’ve seen this problem reported before, but the route to a solution is not clear to me. I read this (Power management - ArchWiki) but nothing jumps at me from there. Same with this (https://classicforum.manjaro.org/index.php?topic=32803.45) and this (Laptop does not suspend when lid is closed) etc.

System info:

 Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=deb59a35-a866-456e-9aad-80eac89d9e75 rw quiet apparmor=1 
  security=apparmor resume=UUID=69d42cc9-b4dd-4683-ab58-fc0f5771ffc5 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X521IA_M533IA 
  v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X521IA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X521IA.303 date: 07/31/2020 
  ID-1: BAT0 charge: 36.6 Wh condition: 50.9/50.0 Wh (102%) volts: 11.9/11.9 
  model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Discharging 
  cycles: 6 
  Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 
  type: MCP arch: Zen family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600106 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 28454 
  Speed: 1397 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1396 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 03:00.0 chip ID: 1002:1636 
  Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo 
  bus ID: 3-3:3 chip ID: 13d3:56a2 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 driver: amdgpu,ati unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.9.11-3-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
  Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 03:00.1 
  chip ID: 1002:1637 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 01:00.0 
  chip ID: 8086:2723 
  IF: wlp1s0 state: up mac: <filter> 
  Local Storage: total: 238.47 GiB used: 9.87 GiB (4.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: SK Hynix model: HFM256GDJTNG-8310A 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 serial: <filter> rev: 80001C00 scheme: GPT 
  ID-1: / raw size: 229.37 GiB size: 224.77 GiB (97.99%) used: 9.86 GiB (4.4%) 
  fs: ext4 dev: /dev/nvme0n1p2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 33.6 C mobo: N/A gpu: amdgpu temp: 33.0 C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 283 Uptime: 8m Memory: 7.26 GiB used: 1.64 GiB (22.6%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1132 lib: 351 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.08 

cat /sys/power/mem_sleep returned this:


systemctl hybrid-sleep works, and if it comes to it, I would be happy with this as an alternative to suspend, but I would need help with that process. However, suspend is what I am looking for and will be first prize.

I don’t know if it’s relevant to this problem, but just in case it is, @megavolt solved a ‘blackscreen boot’ issue earlier where the problem was that the system tried and failed to load a radeon driver when the amd driver supports AMD Renoir: [Solved] Booting to black screen - #14 by megavolt

Any help will be much appreciated…

I just received my HP Envy x360 with 4700U which has the exact same problem.

Check if your bios has an “S3 standby” option or something similar. Lenovo also has put out a custom bios which adds support for S3 standby. If this exists for your laptop that will solve your problem. If you can you should probably still do this even once s2idle works fine.

Linux prior to 5.11 simply does not support s2idle on renoir cpus (or any amd cpus for that matter), and instead just freezes userspace. 5.11 will bring initial support:
www.phoronix. com/scan.php?page=news_item&px=AMD-S2idle-ACPI-Linux-5.11

Unfortunately there still seem to be bugs with the amdgpu driver preventing it from fully working but those are being squared away too, although it could still take some time. For more info and any updates on the current state you can take a look at this issue:
gitlab.freedesktop. org/drm/amd/-/issues/1230

That means in the meantime you’re kinda out of luck if you have no way to enable S3 in your bios. I would recommend using suspend to disk (hibernate) until other options are available (because hybrid standby will drain your battery almost as fast as using it while s2idle isn’t working).

(sorry I can’t post links, you’ll have to remove the spaces)

Suspend seems to be working with kernel 5.14.2-1. Apologies if this is old news already.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.