Failure to connect to firewalld

I built a new LXDE system on a USB flash drive (I first removed the internal SATA drive to prevent a dual-boot). I was able to update and install a few new packages. However, when I tried to access the firewall config, the dialog hesitated for thirty seconds or so and then displayed the error message “failure to connect to firewalld” along with a hint to check that the daemon was running. Should I uninstall firewalld and install ufw/gufw?

Why don’t you follow that hint and do that?

Your choice.
I assume you chose to want to use firewalld for a reason.

I believe firewalld comes by default on Openbox, LXDE, and LXQt. It’s linux-aarhus’ choice for a Firewall, as he builds those ISOs.

So… did you follow this hint?

sudo systemctl status firewalld.service

If it’s not on by default (let us know) and do:

sudo systemctl enable firewalld.service
sudo systemctl start firewalld.service

That is up to you, depending on which firewall you prefer. I prefer the GUI of firewalld over gufw personally.

I did not choose firewalld; it is included by default.

What kind of developer would include an important service such as a firewall and NOT start it by default?

I surfed around a little. firewalld DOT org has a relevant page. The following two commands were able to start firewalld:

systemctl unmask --now firewalld.service
systemctl enable --now firewalld.service

But in the process I noticed that lxterminal is a modified version of the original: no file menu and annoying, not to mention counterproductive, color formatting.

Never mind, I’ll choose a distribution from another Linux family.

It’s more likely just an error. @linux-aarhus can answer this.

Remember, it is also a community edition, not an official edition that you’re using.

It is nice to catch issues and report them to the maintainers.

Alright…? Cool. Have fun wherever you go I guess?

1 Like

Some editions ship with Samba file sharing service but do enable by default.

Some editions ship with UFW but do not enable by default.

Not enabling the service - in this case - the firewalld service per default is a matter of opinion.

Users specifically needing these services are usually smart enough to enable them - and enabling the firewalld service is as simple as

sudo systemctl enable --now firewalld

Now that we touches the subject - you should check the default zone - and the default state of the zone.

Now - the reason that firewalld is chosen is the fact that UFW is creating issues - at least has been (it has been a while since I touched the subject) - when used in connection with a VPN. You can search the archived forum for topics related to UFW if you would like to confirm it.

For the LXterminal - no it is not modified - it just a setting - to enable → rightclick inside → Preferences → Display → Untick Hide menu bar

image


Edit
I have rechecked the profile - the reason the firewalld service was not enabled was a spelling error. It will be correct on the next ISO release.

1 Like

2 posts were split to a new topic: What is the difference with firewalld shields up and shields down