Failure to build package from the AUR, cmake error

Hello, I’ve been trying to install the game rigsofrods from the AUR but have ran into issues.

I input “pamac build rigsofrods” and hit yes instead of editing build files manually.

The build starts but then gets aborted and spits out this error:

usage: conan remote [-h] [-v [V]] [-cc CORE_CONF] {add} ...
conan remote: error: unrecognized arguments: True
ERROR: Exiting with code: 2
CMake Error at cmake/conan.cmake:858 (message):
  Conan remote failed='2'
Call Stack (most recent call first):
  cmake/DependenciesConfig.cmake:5 (conan_add_remote)
  CMakeLists.txt:120 (include)

-- Configuring incomplete, errors occurred!
==> FOUT: Er is een fout opgetreden in build().

If someone could tell me what I’m doing wrong or what I can do to circumvent this error, that would be appreciated.

note: I’m running manjaro on virtualbox with 4 cores, 8gb ram and 40gb storage. I daily drove Linux some years ago and it didn’t go well, so I’m trying to learn different distros before migrating after Windows 10 EOLs.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Someone reported the same error months ago, see the AUR comments.

Noted, though I’m not sure which developers he is referring to, the Rigs of Rods maintainers or cmake.

Game of course. By the way, there is also a binary package in AUR.

I couldn’t figure out how to install the binary package, however, I managed to get it running through itch. Thanks for the help though.

…that was flagged out date about two years ago with no Maintainer. Might want to check details like that before suggesting installing an out of date package. :wink:

Both are versioned from 2022, so I didn’t really care. :stuck_out_tongue:

Then why respond? Should probably work on the caring1 part. :wink:

1 I can’t judge as I’m also working on the same as I’ve also experienced burnout

Conan is used in addition to Cmake etc. Those interact. So unless I know Cmake and Conan, how they build files etc, very well, I move on. I am not a coder, I don’t use build systems or integrations daily.
CI: Introduction to Continuous Integration (CI) — Bincrafters Documentation 0.1.0 documentation
If you want to learn tho, this is your chance. You have a goal. Make it work. You “only” need to figure out how both systems work and what the intention was. Could take a day, could take weeks.

If it is an easy problem, like a missing dependency, be it a command or library, I hunt it down. Just have to figure out packagename and in the case of a command, which library or set of tools provide that command.

Story time:
I come across these things because I compile programs often. All I really need is to know what commands to run. Those almost never work. For bigger builds. Take Mesa for example. I go to Installing MESA — MESA main documentation Tried downloading Mesa SDK. Link doesn’t work. Couldn’t find mirrors or alternative sites for the file. I don’t know fortran or whatever, not trying to get another IDE to make it work. I start looking at other guides. So I try the Mesa 24.0.5 source tarball. That one complained about llvm.wrap, couldn’t figure it out. Compiled LLVM just to try and find llvm-config. Added it to Path. Found llvm-config in many places, added to the path. Still doesn’t work. That was an hour or so wasted. Find this: How to build and use mesa from source · GitHub
It is for Ubuntu. Doesn’t matter. Did I check for dependencies? Nope. Did I install any of them? Nope. I just tried to run the first ‘meson’ command. I know I have ninja/meson. I like that build system, it is simple (for me to use), it is fast, I don’t have to bother with -j8 or any such flags, it uses all my cores by default. Love it. I don’t remember if it complained about a dependency, I don’t think so. You would think I compile for a living because I have most of the stuff installed.
I only built the 64-bit part. “Config with AMD drivers only in release mode, including codecs” Spits out Mesa in my home-folder at the end, I used a prefix. Didn’t want it messing with my systems Mesa.

If you want to install to a prefixed folder, different folder than default which is often /usr or /usr/local, use it during the build process. So the first command should include it. for Meson/Ninja = meson --prefix=“foldername, absolute”. For make, ./configure --prefix=“foldername, absolute”. I don’t think it matters where you put --prefix, first, last. But usually prefix is near the beginning. If for nothing else, for ease of reading and figuring out where all the files go.

Tested a game from Steam, it worked. Goverlay/Mangohud reported Mesa 24.1.0-devel git (In Goverlay-> Metrics->Driver version in the GPU section).
I used the script on the page.

@zhongsiu What??? :scream:

In summary, it sounds like you wasted a lot of time to accomplish nothing.

Sorry, that has nothing to do with this topic. As far as I can tell, the rigsofrods AUR package cannot be built on Manjaro / Arch due to upstream issues.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.