Failing building packages

This is not just one package. I’m using AUR and I get the same CMAKE error message:

==> Starting build()...
CMake Deprecation Warning at CMakeLists.txt:5 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.

CMake Error: CMake was unable to find a build program corresponding to "Unix Makefiles".  CMAKE_MAKE_PROGRAM is not set.  You probably need to select a different build tool.
CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage
CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
-- Configuring incomplete, errors occurred!
See also "/home/froggy/.cache/yay/art-rawconverter/src/art-rawconverter_1.8.3_build/CMakeFiles/CMakeOutput.log".
==> ERROR: A failure occurred in build().

I’ve had the same problem with other packages that had to be compiled.

Here is the CMakeLists.txt that I have:


and it has:

cmake_minimum_required(VERSION 3.14)

any suggestion on how to fix?

Thank you

Do you have the base-devel package group installed?

Do you have base-devel group installed?

sudo pacman -S --needed base-devel

What the other packages you tried to install?

I can check them later tomorrow

Fixed! :grinning:

I was missing the devel components.

BTW, the other package was: opencl-amd were I got the same error. I’ll deal with it tonight.

Again, thank you for all the quick responses

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.