Failed unmounting /home /tmp

Hi Guys,

System reboots normally. It just takes much longer than usual. Up to 2mins. And throwing that error. I think it will clean up on it’s own.
I ran

lsof | grep ‘/home/’

and did not see anything pointing to a problem.
Have you got a more specific command under your sleeve you propose or something that might fix it?

This thread did not mention how to clear the error:

its the watchdog that causes the long reboots, not the home unmount, so disable it:
open this file:
sudo nano /etc/default/grub and put into GRUB_CMDLINE_LINUX_DEFAULT the following kernel parameter:
dont remove anything from there, just add it inside the quotes to already existing parameters; press ctrl+x to save it, then update grub:
sudo update-grub

Create this file:
sudo nano /etc/modprobe.d/blacklist.conf
Put there these lines:
blacklist iTCO_wdt
blacklist iTCO_vendor_support
Then CTRL+X, to save the file
Recreate initframs:
sudo mkinitcpio -P

1 Like

Thanks a lot for chiming in! :slight_smile:

Should be like this right?


Now it throws a lot of the usual shutdown info lines. And in the middle of these lines the home and temp error still happen.

As for the rest, i did it like you told me to do.

Could this lead to a bigger issue or it’s mostly harmless?
Should i just ignore it and keep using the OS as normal?

If you recommend something else i will do it. I just want to make sure i don’t render the OS useless :smiley:

i told you to not remove anything from the grub cmdline !!!
is this how your grub line actually looks like?:

This is the original, btw - in case you now need it :wink:

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3

The line was

GRUB_CMDLINE_LINUX_DEFAULT=“quiet resume=UUID=blabla-bla-5g4b-22dr-blablabla udev.log_priority=3”

I changed some chars because i am not sure if the UUID contains sensitive info

Where does the nowatchdog text go exactly? I have put it in front of the number 3, but it does not solve the error!

Mine is different. I took note of it :wink:

I changed some chars when i replied @brahma because i am not sure if the UUID contains sensitive info

ok so your grub line looks ok then except these qoutes of yours:

this is how the qoutes should look like in your actual grub:

"quiet resume=UUID=blabla-bla-5g4b-22dr-blablabla udev.log_priority=3"

now check if the watchdog was succesfully disabled with these:
cat /proc/sys/kernel/watchdog
cat /proc/sys/kernel/nmi_watchdog
both should return ‘0’

I have inserted GRUB_CMDLINE_LINUX_DEFAULT= the way it was before.

So kernel parameter: nowatchdog is not meant to be somewhere in the original line?
If it is, exactly where?

Both kernel/watchdog and kernel/nmi_watchdog return 0.

yes it should be to completely disable watchdog … it doesnt matter where you put it in the line, it just have to be inside the quotes and there needs to be a space between each parameter …

for example:

… no, there is no line break/newline there - the line is just too long, there is just one space after udev.log_priority=3

yes, like that - and you may as well save your effort cloaking the UUID - it’s just a random number no one is interested in
the only one who cares is … your own computer :wink:

thanks for pointing that out :wink:

the error still happens though…

btw how can i quote you like you did to me here?

Error still happens and sometimes my desktop does not load with the taskbar.

Most likely not related. But wondering if this rings a bell?

with error you mean the failed unmount home?
you need to fing out what program are you running thats causing it… for example torrents, some sync program etc… before shuting down, close all running programs and then check with the task manager for potential programs that are running in the backround …

and for the taskbar issue, post system info + logs:
inxi -Faz
journalctl -b0 -p4 --no-pager

for real?
… through the magic of highlighting, then copy and paste

you write in a window bottom left when you reply
the preview of it is in the right side window

did you not notice all the little symbols, the menu in the top row of it?
the most used is blockquote and preformatted text
hover the symbols to see the meaning
highlight whatever text, then click the symbol …

… I feel silly actually describing this …

Brother i appreciate you!
I feel silly myself i asked you this!

Believe me I tried every option several times less the bubble icon :man_facepalming:

For some reason i missed it…

Hello @888,

when I read the kernel message, then I conclude the following:

There is a java program, which is still running und probably has a internet connection (because of ufw) and still access /home and /tmp.Your OS cannot gently close this program and therefore it make to close by force even if this produce errors. Watchdog is a function that ensures that the OS will do a shutdown/reboot and don’t hang at that point. Most valuable on headless machines where you don’t have access to a power/reset button.

So, find the java program and close it before rebooting.

1 Like

Dear @megavolt

Just before i saw your reply i was thinking the same thing.
Even the image below shows that.

I also noticed that sometimes Megasync app crashes after booting.
The app is java based, and i believe is the culprit.

I will test eventually and confirm :male_detective: