Failed to update an outdated Manjaro installation

Hello, folks

I have a Manjaro installation that I didnt update since february / 2022, I guess. So I tried to update it with manjaro-chroot on a pendrive, but I saw an error

:: Import PGP key 150C200743ED46D8, "Mark Wagie <mark@manjaro.org>"? [Y/n] 
error: key "150C200743ED46D8" could not be looked up remotely

Can someone send me the PGP key of this man called Mark Wagie? So I import it manually and then the pacman on manjaro-chroot can skip this error

Thanks

Hello,

Is the forum search failing for you?

2 Likes

Man, yes, forum searching is going fine here, thanks.

I tried EVERYTHING in this posts you post there, refresh and populate keys and many others solutions in all Manjaro Forum and all Manjaro Foruns around the Internet and NOTHING worked here.

Only the key from Mark Wagie was in problems, but I tried to update keys from Ubuntu servers

Change keyserver

If you suspect that something is not working right with the keyserver, you could try to switch to the Ubuntu keyserver. To do this, edit /etc/pacman.d/gnupg/gpg.conf and change the keyserver line to:

keyserver hkp://keyserver.ubuntu.com

and disabled key signature verification and the system could update the packages.

Remembering all you, this system didn’t received any update since 31-03-2021 maybe, so much outdated.

To bring solution I removed some packages with pacman -Rdd and the update occured well, many hours in front of the notebook to do this…

Anyway, thanks.

For future reference: if the last time that system had been updated was in March of 2021, the signature keys available to the system would have been too old to verify newer packages. Those keys can expire as soon as 6 months after being released (although usually longer).

Disabling all key signature validation works (as you discovered), but is not recommended for most of the updates.

A less drastic approach would have been to disable the key signature verification, update only the keyring packages, then re-enable the verification. I’ve explained how to do this in a previous post.

There is also a script I’ve written that you might be interested in. It incorporates that fix, along with other manual package changes I’ve come across. I frequently test it against older installs to better automate the update process for those (not officially supported by manjaro devs, use at your own risk, etc, etc). In the event that you need to update another older install, the list of manual changes can be a good reference.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.