Failed to synchronize all databases (no servers configured for repository)

I have a laptop that haven’t used or update for awhile. I decided to update, but cannot synchronize no matter what I do.

“failed to synchronize all databases (no servers configured for repository)”

I’ve tried the following with no success:
sudo pacman-mirrors --country United_States && sudo pacman -Syyu (Failed)
sudo pacman-mirrors -f5 && sudo pacman -Syyu (Failed)

System: Kernel: 5.10.79-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
Desktop: KDE Plasma 5.23.3 Distro: Manjaro Linux base: Arch Linux
Machine: Type: Laptop System: TOSHIBA product: Satellite L855 v: PSKFUU-0RR004

Graphics: Device-1: Intel 3rd Gen Core processor Graphics vendor: Toshiba driver: i915
v: kernel bus-ID: 00:02.0

First thing, always provide output of these commands,

but here you have possible solution:
open as root /etc/pacman.d/mirrorlist and replace everything(basically empty the file) in it with
Server =$repo/$arch
and do sudo pacman -Syyu

you can replace “stable” with your desired branch

I tried “sudo -i”
Now I’m logged in as root.
Typed “etc/pacman.d/mirrorlist”
I get “permission denied”

Never mind, I figured it out. I did the following:
sudo pacman-mirrors --api --set-branch ‘stable’
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
Then pamac update

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.