Failed to start Mount removable media on sda1

That looks promising too, but with Arch parlance.

1 Like

Couple of things I see in your fstab.

  1. Your line for swap looks like this:

UUID=82582173-f957-4a03-b3b5-289447c2726d swap swap defaults,noatime,discard 0 1

but AFAIK (and the way it is on my desktop) it should look like this:

UUID=82582173-f957-4a03-b3b5-289447c2726d none swap defaults 0 0

  1. Then this line:

tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

can be safely removed. I read about it not too long ago here: Manjaro Wiki page about `/etc/fstab` needs corrections

1 Like

I just updated my laptop last night and mounting my external usb drive has been broken since. I had another laptop that wasn’t updated and it worked fine. I updated it and getting the same result now.

edit: wrong thread issue.
My NTFS external USB not mounting was solved in

This is minor, but
media-mount != mount-media

2 Likes

I’m not sure of the need for the mask, but:

tmpfs /tmp tmpfs defaults 0 0

should normally suffice.

But that line isn’t even needed, see the discussion I linked to.

1 Like

Without checking the link, I presume it was @Aragorn’s post; which I tend to agree with. which doesn’t detract from my comment, regardless of whether its needed. However, I still don’t understand the OP’s apparent need for the mask.

On the possibility of delay mounting: This could be a job for @scotty65 who seems to enjoy a scripting challenge.

It’s a default, created by some utilities — possibly some partition manager, or calamares.


If the drive is removable, then I would certainly also add nofail. Saves the system from stalling if polling the drive times out. :wink:

1 Like

Opening another avenue of investigation, I just found this:

… which might possibly be related, given the timeframe.

I’m afraid that I have no experience at all in mounting disks - my PC has 1 internal HDD & 1 external HDD that is mounted by Plasma upon login. And I am still quite inexperienced with systemd - I can write a timer to run a job as a user, but I’ve never written anything to do with the system.

These links may help (if you haven’t already had a look at them):

systemd.mount — Mount unit configuration

1 Like

For clarity’s sake: the disks do get mounted. I can access all data on them, and mount -a confirms this by not making any changes.

The problem is that Manjaro seems to think that my internal disks are removables, like USB sticks or something, and that the mount service doesn’t start.

As a result, accessing the disks consumes several seconds.

:point_up: :point_up: :point_up: :point_up: :point_up: Since the possibility is that there is simply a timeout, :point_up: :point_up: :point_up: :point_up: :point_up:

Scroll up even further. :wink:

Nope. That’s why I added the quote. Makes scrolling unnecessary. :wink:

I’d need to find out why the media-mount service doesn’t start, or why Manjaro thinks that my hard disks are external. That is the actual culprit, I think.

What’s the output of:

systemctl list-units | grep --ignore-case sda

systemctl list-units | grep --ignore-case sda gives:

  sys-devices-pci0000:00-0000:00:02.1-0000:02:00.1-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda1.device  loaded active plugged   TOSHIBA_MG09ACA18TE 1
  sys-devices-pci0000:00-0000:00:02.1-0000:02:00.1-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda2.device  loaded active plugged   TOSHIBA_MG09ACA18TE 2
  sys-devices-pci0000:00-0000:00:02.1-0000:02:00.1-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda3.device  loaded active plugged   TOSHIBA_MG09ACA18TE 3
  sys-devices-pci0000:00-0000:00:02.1-0000:02:00.1-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda4.device  loaded active plugged   TOSHIBA_MG09ACA18TE 4
  sys-devices-pci0000:00-0000:00:02.1-0000:02:00.1-ata1-host0-target0:0:0-0:0:0:0-block-sda.device       loaded active plugged   TOSHIBA_MG09ACA18TE
● media-mount@sda1.service                                                                               loaded failed failed    Mount removable media on sda1
● media-mount@sda2.service                                                                               loaded failed failed    Mount removable media on sda2
● media-mount@sda3.service                                                                               loaded failed failed    Mount removable media on sda3
● media-mount@sda4.service                                                                               loaded failed failed    Mount removable media on sda4

I re-installed the system, and the problem is over now.

Another rather minor issue popped up, but I’ll start a new thread about it later, since it’s totally not related to this one.

1 Like

The drives are now showing as internal; is that right?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.