Failed to Start Load/save Screen Backlight

Hello everyone, this is my first post, I’ve been using Manjaro as my main OS for the past 3 months, so I’m still learning the ropes.

In this time, I’ve encountered and solved some issues along the way, but there’s one in particular that I’ve had since the very beginning that I have been unable to solve despite doing a fair amount of research:

Every time my computer boots, I get the following errors:

No irq handler for vector
Failer to start Load/save screen backlight brightness of backlight: acpi_video0

the computer works fine, but my computer takes longer to boot than it should. Also I’ve been having issues with Libreoffice, but right now I’m focused on trying to solve this one, so I would really appreciate if someone out there could point me in the right direction

  Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=230f6c0e-aeae-442d-ba76-2e95d91c9bc0 rw quiet apparmor=1 
  security=apparmor resume=UUID=e2ea20d8-3ead-4a91-9475-0ff24a78271e 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 81FB v: 330S-15ARR serial: <filter> 
  Chassis: type: 10 v: 330S-15ARR serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: 31900002 WIN serial: <filter> 
  UEFI: LENOVO v: 7WCN37WW date: 05/22/2019 
  ID-1: BAT1 charge: 23.5 Wh condition: 27.8/30.0 Wh (93%) volts: 8.2/7.4 
  model: LENOVO BASE-BAT type: Li-poly serial: <filter> status: Charging 
  cycles: 210 
  Topology: Dual Core model: AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 11 (17) 
  stepping: N/A microcode: 810100B L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 19972 
  Speed: 1495 MHz min/max: 1600/2500 MHz boost: enabled Core speeds (MHz): 
  1: 2234 2: 2503 3: 2089 4: 2046 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: Lenovo driver: amdgpu v: kernel bus ID: 03:00.0 chip ID: 1002:15dd 
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus ID: 3-1:2 
  chip ID: 174f:2426 serial: <filter> 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu 
  FAILED: ati unloaded: modesetting alternate: fbdev,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: AMD RAVEN (DRM 3.38.0 5.8.6-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.7 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 03:00.1 chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x bus ID: 03:00.5 
  chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 03:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.8.6-1-MANJARO 
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ce v: N/A modules: 8821ce port: 2000 
  bus ID: 01:00.0 chip ID: 10ec:c821 
  IF: wlp1s0 state: up mac: <filter> 
  Local Storage: total: 1.82 TiB used: 380.99 GiB (20.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: LDM2 scheme: GPT 
  ID-1: / raw size: 1.52 TiB size: 1.50 TiB (98.37%) used: 380.99 GiB (24.8%) 
  fs: ext4 dev: /dev/sda7 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda5 
  System Temperatures: cpu: 55.6 C mobo: N/A gpu: amdgpu temp: 55 C 
  Fan Speeds (RPM): N/A 
  Processes: 230 Uptime: 5h 23m Memory: 6.76 GiB used: 2.38 GiB (35.2%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: 1340 pacman: 1337 
  lib: 360 flatpak: 0 snap: 3 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.05 

Try adding the acpi_backlight=vendor kernel parameter to your GRUB_CMDLINE_LINUX line in /etc/default/grub.

1 Like

Thank you for your answer.

I just tried it and it didn’t work

But I got a slightly different error

actually I think it got worse, my computer is now randomly changing the screen brightness. I don’t know what could have caused this

Try one of the other variations.

I think you misplace the option, it should be in the line before, just after udev.log_priority=3. Then sudo update-gub
About the other error, you can try and add in the same line acpi_osi=Linux.
After every edit on the grub file, you must do sudo update-grub.
Also you can take a look at this thread

As far as functionality, it doesn’t matter which line a parameter is added to or what order they’re in. For ease of merging pacnew files, it’s better to add custom parameters to GRUB_CMDLINE_LINUX and leave GRUB_CMDLINE_LINUX_DEFAULT as is.

1 Like

You’ll never going to sleep without learn something new. Spanish say.
Nunca te acostarás sin saber alguna cosa más


Hello, I just finished trying both the native and the video variations
both video and native remove the "Failed to start load/save screen from the boot prompt and replace it with the one on the screenshot below
however video disables my brightness hotkey and native keeps the brightness at 100 % all the time (the hotkeys work, but the brightness remains static)

I haven’t tried this yet. I’m still very new to linux and that fix seems a bit more technical, so I’m going to research a bit more before I actually try it

It’s exactly the same thing you just did with an additional parameter: acpi_osi=Linux.

What’s posted there is just “a bit more technical” way of accomplishing it. :wink: