Failed to start Load Kernel Modules specifically nvidia modules

Every time I try and boot I get a failed to load kernel modules screen

System will allow me to get to other tty sessions. I have attempted reinstalling the nvidia drivers from scratch and using different kernels. I have also done manjaro-chroot with a live boot and attempted updates and reinstalls.

journalctl -p 4 -b

systemd-modules-load[336]: Failed to insert module ‘nvidia’: Exec format error

kernel: 5.10.30-1-MANJARO

I am not sure where to go from here or what other information would help.

What’s the output of uname -r and modinfo nvidia | grep vermagic? Which nvidia packages are installed?

uname -r

5.10.30-1-MANJARO

modinfo nvidia | grep vermagic:

vermagic: 5.10.34-1-MANJARO SMP mod_unload

pacman -Q | grep nvidia

ib32-nvidia-utills 460.73.01-1
linux510-nvidia 460.73.01-3
linux512-nvidia 460.73.01-3
linux54-nvidia 460.73.01-3
mhwd-nvidia 460.73.01-1
mhwd-nvidia 340xx 340.108-1
mhwd-nvidia 390xx 390.143-1
nvidia-utils 460.73.01-3
opencl-nvidia 460.73.01-3

As you can see the running kernel version and the module’s vermagic don’t match. The kernel will reject this module without appropriate options. What’s the linux510 package version?

The linux verion is
linux510 5.10.34-1

That’s interesting, then. Do you use GRUB? If so, what’s the output of grep -o 'Kernel: [a-zA-Z0-9.-]*' /boot/grub/grub.cfg | sort | uniq?

I do use grub the output of the command is:

Kernel: 5.10.34-1-MANJARO
Kernel: 5.12.1-2-MANJARO
Kernel: 5.4.116-1-MANJARO

uname -r still gives 5.10.30-1

Can you reboot and select “Manjaro Linux (Kernel: 5.10.34-1-MANJARO x64)” specifically in the boot menu?

I just went into 5.4 (same issue) but reinstalled 510. I am now no longer able to get to the grub screen and am chucked straight into 5.4

I managed to get back to grub and manually selected 10.34-1 and journalctl is still giving version magic ‘5.10.34-1MANJARO SMP mod_unloaded’ should be ‘5.10.30-1-MANJARO mod_unloaded’

Have you tried reinstalling the linux510 package? What does cat /boot/linux510-x86_64.kver say?

I live booted and reinstalled linux510. When trying to boot into 510 from grub I am still getting failed to load kernel modules.
cat /boot/linux510-x86_64.kver gives:

5.10.34-1-MANJARO x64

uname -r gives

5.10.30-1-MANJARO

Something appears to be very broken

As I had my home directory as a separate partition I ended up doing a complete reinstall of manjaro and just copying over the things I needed which worked. I must have borked something when doing a paru update. Oh well. Thank you for your help so far