Failed to start load kernel modules error on boot

Hi. I’m new to the forum and new to linux so I really don’t have any idea what I’m doing, so please go easy on me. :slight_smile:

I tried some distros in vbox and settled on Manjaro. Just bought a new HP Pavilion laptop, AMD Ryzen 5 with AMD Radeon Graphics. I installed the iso on a usb drive, booted it up and chose to overwrite Windows 10 and install Manjaro. Started out with everything working fine. Since I have so much free disk space I thought I’d install VirtualBox, but it gave me a kernel error. I searched the web and forums, but nothing worked and it couldn’t update the kernel.

Then, I noticed when the computer boots up it gives a couple of lines at the top and one of them was the Failed to start load kernel modules error.

I checked the forum again, but the answers seemed to pertain to nvidia graphics, not amd. There was also one solution I tried that said to type in sudo pacman -S linux510. I do have the 510 kernel, so I tried it in Konsole and got a long list of error 403 and 404’s and it couldn’t find the directories, whatever that means and it ended saying it couldn’t install. Wifi is working, so I know that’s not the problem.

So, I really don’t know what to do and I’m hoping someone can help. If you need more info, please tell me what to do to give it to you.

BTW, everything boots up and works just fine, but I’m sure this is something that needs to be fixed.



You need the modules as well. The modules are based on what kernel you are using. If you’re on Kernel 5.10, you’d want to install linux510-virtualbox-host-modules as well. If on Kernel 5.11, you’d want linux511-virtualbox-host-modules, etc.

You’ll probably want the virtual box extension pack as well.

You can get it from AUR, if you don’t know what AUR is, please read these articles before moving on:

pamac build virtualbox-ext-oracle will install this package.

Alternatively, you can download the extension pack from the official website and use that.

It’ll be easier to use our GUI for kernel management. Open up Manjaro Settings Manager, and go to Kernel.

It is part of the Manjaro Hardware Detection suite.

I opened the Manjaro Settings Manager. It say 510 running - installed. Do I remove it and reinstall it?

No, there is no need to remove it and reinstall it.

Okay. Sorry, but I don’t understand what I’m supposed to do then to get rid of the kernel modules error when I boot up and shut down.

Alrighty. I did at least figure that out. I had installed the vbox host modules so I don’t know why it wouldn’t work. I just said to heck with vbox, I really don’t need it so I deleted it and the host modules and guest additions and just for the heck of it rebooted and I did not get the failed to start load kernel modules error when I booted up. I didn’t know that the boot error referred to vbox. I thought something was screwed up in my system, but now it’s gone and everything looks good. I really appreciate your help. Thanks.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.