'Failed to start Load Kernel Modules' after reboot

Same error as before, only difference is that the option to boot Windows disappearedā€¦ :sweat_smile: :see_no_evil:

ok so chroot again nad reinstall the 5.17 kernel:
mhwd-kernel -r linux517
install again:
mhwd-kernel -i linux517
run this:
and copy the output from this command here

In chroot, make sure to run the update again before going into more troubleshooting.
Boot from live USB and do

manjaro-chroot -a

pacman-mirrors -c Global && pacman -Syyu

then you can try to reinstall the video drivers again. This way you are sure you donā€™t have a mismatch of packages due to wrong mirror sync or something like that.


Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.15-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.15-x86_64.img
Found initrd fallback image: /boot/initramfs-5.15-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your device.map.
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

@omano ok i did that and uninstall:
sudo mhwd -r pci video-nvidia
install again:
sudo mhwd -i pci video-nvidia

Should I now reboot again or is anything left to do before?

windows is not being detected, very interestingā€¦
now install also headers, since they were mentioned aboveā€¦
pamac install linux515-headers linux517-headers
then run again:
mkinitcpio -P
systemctl reboot

Now it worked, thank you so much!!!

Only thing was no Windows in Grub, but after logging into Manjaro I did update-grub again and then it workedā€¦ :man_shrugging: