Failed to start Light Display Manager while trying to change greeter

Okay, I’m really new to Linux so I have been using Manjaro for a couple of weeks now, sadly I decided to be a bit more creative without any real technical skills to change my greeter, what I did was:
Installed a package called “lightdm-webkit2-greeter” from pamac, then I installed a webkit2 theme called “obsidian”, afterwards I used the command “sudo nano /etc/lightdm/lightdm.conf” to change “greeter-session=lightdm-gtk-greeter” to “greeter-session=lightdm-webkit2-greeter” and then used “sudo nano /etc/lightdm/lightdm-webkit2-greeter.conf” to apply the obsidian theme. And now when I start my computer It appears as "Failed to start Light Display Manager " (4 times); I tried to change “greeter-session=lightdm-webkit2-greeter” back to “greeter-session=lightdm-gtk-greeter” (on the Terminal) and it still appears the Errors, I’m confident it is a small error but I have yet to find the soulution, anyway thank you for your time and I apologies for my bad English!
My specs:
OS: Manjaro Linux x86_64
Host: Thinkpad L560
Kernel: 5.15.28-1MANJARO
Packages: 1196 (pacman)
Shell: bash 5.1.16
CPU: Intel i5-6300 3.00 GHz
GPU: Intel Skylake GT2 (HD GRAPHICS 520)
Memory: 150 MiB / 7738 MiB
I have acces to the internet as well!

When you are stuck at the above screen, press CTRL+ALT+F2 to reach the console mode.
Then log in using any admin id and password. You can log in using your usual user id and when required you can provide the sudo password as well.
usually root is used but you can your user id and password for that

systemctl status lightdm

If it gives you status GREEN then something else is broken.

Next, try to run the following command to start lightdm as test mode with debugging switch. This would try to launch lightdm and show you any errors, warnings.

lightdm --test-mode --debug

Please share your results with us
Some obvious issues might be like
Lightdm successfully loads everything but in the end, it is not able to find the greeter And for this case, somehow the greeter is corrupted. So, the obvious corrective step is to reinstall the greeter and repeating the process.

pacman -S lightdm-gtk-greeter

Then enable the systemd service for lightdm, just in case.

systemctl enable lightdm

And then reboot –

systemctl reboot

Other Solutions

If above steps did not work, you might want to go over the following troubleshooting options as well. These may work.

  1. Xorg server is corrupted or not installed. Hence, lightdm is not able to communicate with xorg. Reinstalling xorg package would help. You can reinstall in Arch Linux just using pacman -S xorg .
  2. Sometimes the lightdm-gtk-greeter-settings package misconfiguration causes this error. So reinstalling lightdm-gtk-greeter-settings can help as well.
  3. It always recommended checking whether you have the lightdm service enabled via systemd.
  4. In the end, check the log of debug mode command carefully. You would find the possible cause of this problem.
  5. Verify the lightdm log file and xorg log file in the following path for any errors or warnings. The lightdm log file: /var/log/lightdm/lightdm.log . And the xorg log file /var/log/lightdm/
  6. If you have an advanced system that boots in superfast mode, then lightdm and graphics drivers may run into race conditions. The lightdm service may start before the Kernel loads the graphics drivers. If this is the case, you may try to add the following lines in the /etc/lightdm/lightdm.conf file under [lightDM] section.


Historically, Nvidia driver updates may cause issues with xorg and lightdm as well. As lightdm depends on xorg to work properly, it might be needed to fix xorg also for errors. The following commands you may use to reconfigure xorg after purging Nvidia driver.

cp /etc/X11/xorg.conf /etc/X11/xorg_backup.conf
sudo Xorg -configure
cp /root/ /etc/X11/xorg.conf

If you have your problem solved then mark the solution box to let other know which method worked for you
Have a great day :slightly_smiling_face:

For a tip
I remember dealing with similar issue when I was quite new to GNU/Linux.
Linux is not a operating system or rather a code that interacts with your hardware in simple words
So I messed up the installation of Lightdm in Ubuntu where tweaking is bit more complicated…
Still now I run into issues and find myself quite newbish because the horizon of this Linux journey is quite beyond our imagination.

  1. I suggest you take a look into Arch wiki when you are trying to install something. Follow the procedure given in the wiki… It is not just going to help you in your installation but help you deal with issue that you might run into if you follow some Youtube channel. IK most of new users search things on Youtube but I suggest not to because not only will be your system different but also you will have no idea to step back from the point they taught you… If you know what you are doing then Youtube Videos are quite entertaining… Just don’t follow random youtube…
    Reason I am suggesting Arch wiki is because Arch wiki is by far the best wiki on the Internet. There you will see solution to common problem and everything you need to know

  2. Try Searching the problem copying the exact message on the screen in your browser and find solution regarding that…

  3. Its necessary you do research on your own….
    Since you are new you may not understand some terms or things
    You can ask those terms on Internet like on Subreddit, Discussion Groups to dive even further or there already exist information about that topic

  4. Most important of all don’t panic… Your research may take sometime depending on your current knowledge. I personally love facing issues because the Information I receive at the end from a single issue is pretty awesome

And don’t worry about English I too have really bad Grammar

Best of Luck and have a great Journey :slightly_smiling_face:

1 Like

Can you rename your title ?
Your title should be affiliated with something you are dealing with
Renaming to Failed to start Light Display Manager would be better
Although your current title is good but it doesn’t explain your issues quite a lot for others

OK it didn’t worked, when I use “lightdm --test-mode --debug” it shows that it doesn’t even exist: ”Failed to load configuration from / etc/lightdm/ lightdm.conf: Key file contains line:?: [Seat: *] ? which is not a key-value pair, group, or comment", also when I try to enable lightdm (after reinstalling) it appears some sort of authentification to manage system services or unit files and then put my password, afterwards it says “authentication complete” and returns me to command line, when I reboot the error still occurs. Probably just gonna fresh install it again, I have only used it for 2 weeks and my personal stuff are in a Hard drive…
Thanks for your time kind sir!

1 Like

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots … below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

You are welcome :slight_smile:

sudo systemctl status lightdm

This would have given you the problem you have encountered or if

lightdm --test-mode --debug

didn’t work you could have just tried

lightdm --debug

Here are some useful option you can play with

lightdm --help
lightdm [OPTION?] - Display Manager
Help Options:
-h, --help Show help options
Application Options:
-c, --config=FILE Use configuration file
-d, --debug Print debugging messages
–test-mode Run as unprivileged user, skipping things that require root access
–pid-file=FILE File to write PID into
–log-dir=DIRECTORY Directory to write logs to
–run-dir=DIRECTORY Directory to store running state
–cache-dir=DIRECTORY Directory to cache information
–show-config Show combined configuration
-v, --version Show release version

I suggest you to take a look into THIS LINK.
I also suggest you to install a alternative display mangerlike sddm incase lightdm fails to opens or doesnot open at all…
At that case do this

When you are stuck at the above screen, press CTRL+ALT+F2 to reach the console mode. (As usual)
login using root id and password

systemctl disable lightdm
systemctl enable sddm

In place of sddm you can put the display manager of your choice that you have installed as a alternative…Also You may not always have your backup with you… This is just incase situation…
Hope you have a great time in Manjaro and Linux as a whole

Have a great day :slight_smile: