Failed to start File System Check on Root Device after kernel remove

Here is the error message that I get when I boot on my machine:

Here is the messages that I have on the boot:
[FAILED] Failed to start File System Check on Root Device.
[ OK ] Finished Record System Boot/Shutdown in ...
[ OK ] Finished rebuild Journal Catalog.
[ OK ] Reached target sound card.
[ OK ] Started network time synchronisation.
[ OK ] Reached target Bluetooth Support.
[ OK ] Reached target system Time set.
[ OK ] Finished rebuild dynamic linked cache
       Starting update is completed...
[ OK ] FInished update is completed.
[ OK ] Started Load/Save RF Kill switch status.
You are in emergency mode, after logging in type "journalctl -xb" to view system logs, "systemctl reboot" to reboot, "systemctl default" or "exit" to boot into default mode.

Cannot open access to console, the root account is locked.
See sulogin(S) man page for details,

Press Enter to continue.

I want to specify that this happened after I removed linux kernel v.5.4:

sudo mhwd-kernel -r linux54
sudo pacman -R linux54-headers
sudo pacman -R linux54-extramodules

And tried to remove v.5.10 but failed:

sudo mhwd-kernel -r linux510-rt
sudo pacman -R linux510-rt-headers
sudo pacman -R linux510-rt-extramodules  

Here are all my installed kernels:

$ mhwd-kernel -li
Currently running: 5.12.19-1-MANJARO (linux512)
The following kernels are installed in your system:
   * linux510
   * linux511
   * linux512
   * linux510-rt
   * linux511-rt

I am unable to remove linux510-rt, linux511-rt and linux511 maybe it is linked with my problem?


Here is infos about my system:

$ inxi -F
  Host: manjaro Kernel: 5.12.19-1-MANJARO x86_64 bits: 64 
  Desktop: GNOME 40.3 Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: B450 I AORUS PRO WIFI v: N/A 
  serial: <superuser required> 
  Mobo: Gigabyte model: B450 I AORUS PRO WIFI-CF v: x.x 
  serial: <superuser required> UEFI: American Megatrends v: F51 
  date: 07/29/2020 
  Info: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP cache: 
  L2: 4 MiB 
  Speed: 3169 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 3169 2: 2154 
  3: 3594 4: 2137 5: 2196 6: 2196 7: 2196 8: 2194 9: 4262 10: 2057 11: 2196 
  12: 2196 13: 2195 14: 2196 15: 3906 16: 2081 
  Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] driver: amdgpu 
  v: kernel 
  Device-2: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo 
  Display: wayland server: 1.20.11 driver: loaded: amdgpu 
  note: n/a (using device driver) - try sudo/root 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Radeon RX 5500 XT (NAVI14 DRM 3.40.0 5.12.19-1-MANJARO 
  LLVM 12.0.1) 
  v: 4.6 Mesa 21.1.5 
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel 
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel 
  Device-3: Razer USA Kraken Tournament Edition type: USB 
  driver: hid-generic,snd-usb-audio,usbhid 
  Device-4: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo 
  Sound Server-1: ALSA v: k5.12.19-1-MANJARO running: yes 
  Sound Server-2: PulseAudio v: 14.2 running: yes 
  Sound Server-3: PipeWire v: 0.3.32 running: yes 
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi 
  IF: wlp7s0 state: down mac: 7e:b9:88:dc:e5:20 
  Device-2: Intel I211 Gigabit Network driver: igb 
  IF: enp9s0 state: up speed: 1000 Mbps duplex: full mac: 18:c0:4d:2d:6e:d9 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Local Storage: total: 1.01 TiB used: 337.64 GiB (32.8%) 
  ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP510 size: 447.13 GiB 
  ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
  ID-3: /dev/sdb type: USB vendor: Corsair model: Corsair Voyager SliderX2 
  size: 118 GiB 
  ID-1: / size: 404.85 GiB used: 270.14 GiB (66.7%) fs: ext4 dev: /dev/dm-0 
  ID-2: /boot/efi size: 299.4 MiB used: 476 KiB (0.2%) fs: vfat 
  dev: /dev/nvme0n1p1 
  ID-1: swap-1 type: partition size: 34.51 GiB used: 0 KiB (0.0%) 
  dev: /dev/dm-1 
  System Temperatures: cpu: 51.4 C mobo: N/A gpu: amdgpu temp: 37.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
  Processes: 412 Uptime: 16m Memory: 31.37 GiB used: 2.98 GiB (9.5%) 
  Shell: Zsh inxi: 3.3.06 

The logs of the journal:

$ journalctl -p3 -b-1
-- Journal begins at Wed 2021-01-20 10:01:00 CET, ends at Thu 2021-07-29 08:09:58 CEST. --
Jul 28 19:19:02 manjaro systemd-fsck[432]: fsck failed with exit status 4.
Jul 28 19:19:02 manjaro systemd[1]: Failed to start File System Check on Root Device.
Jul 28 19:19:36 manjaro gdm-password][3329]: gkr-pam: unable to locate daemon control file
Jul 28 19:19:39 manjaro systemd[3344]: Failed to start Application launched by gnome-session-binary.
Jul 28 19:19:39 manjaro pulseaudio[3526]: Found duplicated D-Bus path for adapter /org/bluez/hci0
Jul 28 19:19:39 manjaro bluetoothd[3843]: Failed to set mode: Blocked through rfkill (0x12)
Jul 28 19:26:30 manjaro systemd-coredump[6081]: [🡕] Process 5821 (ledger-live-des) of user 1000 dumped core.
                                                Stack trace of thread 5835:
                                                #0  0x00007f513a055af3 n/a ( + 0x12af3)
                                                #1  0x00007f513a056729 udev_monitor_receive_device ( + 0x13729)
                                                #2  0x00007f513a076bf5 n/a (/tmp/.org.chromium.Chromium.QXKsRX + 0x7bf5)
                                                #3  0x0000559a9888dc54 n/a (ledger-live-desktop + 0x18f1c54)
                                                #4  0x00007f515fb58259 start_thread ( + 0x9259)
                                                #5  0x00007f515e4b15e3 __clone ( + 0xfe5e3)
                                                Stack trace of thread 5821:
                                                #0  0x00007f515fb648ca __futex_abstimed_wait_common64 ( + 0x158ca)
                                                #1  0x00007f515fb59743 __pthread_clockjoin_ex ( + 0xa743)
                                                #2  0x0000559a9889bf4e uv_thread_join (ledger-live-desktop + 0x18fff4e)
                                                #3  0x0000559a9888d48b n/a (ledger-live-desktop + 0x18f148b)
                                                #4  0x0000559a9889077c uv_library_shutdown (ledger-live-desktop + 0x18f477c)
                                                #5  0x00007f51602071a4 _dl_fini ( + 0x101a4)
                                                #6  0x00007f515e3f24a7 __run_exit_handlers ( + 0x3f4a7)
                                                #7  0x00007f515e3f264e exit ( + 0x3f64e)
                                                #8  0x0000559a9e6cab6f n/a (ledger-live-desktop + 0x772eb6f)
                                                #9  0x0000559a99662931 n/a (ledger-live-desktop + 0x26c6931)
                                                #10 0x0000559a99661e8b n/a (ledger-live-desktop + 0x26c5e8b)
                                                #11 0x0000559a996614a1 n/a (ledger-live-desktop + 0x26c54a1)
                                                #12 0x0000559a9a043078 n/a (ledger-live-desktop + 0x30a7078)
                                                #13 0x0000559a99fd50f8 n/a (ledger-live-desktop + 0x30390f8)
                                                #14 0x0000559a99fd50f8 n/a (ledger-live-desktop + 0x30390f8)
                                                #15 0x00001d48000b7147 n/a (n/a + 0x0)
                                                #16 0x00001d48001fa988 n/a (n/a + 0x0)
                                                #17 0x0000559a99fcd558 n/a (ledger-live-desktop + 0x3031558)
                                                #18 0x0000559a99fd50f8 n/a (ledger-live-desktop + 0x30390f8)
                                                #19 0x0000559a99fd50f8 n/a (ledger-live-desktop + 0x30390f8)
                                                #20 0x0000559a99fd2c1b n/a (ledger-live-desktop + 0x3036c1b)
                                                #21 0x0000559a99fd29f8 n/a (ledger-live-desktop + 0x30369f8)
                                                #22 0x0000559a9970e9ac n/a (ledger-live-desktop + 0x27729ac)
                                                #23 0x0000559a9970de27 _ZN2v88internal9Execution4CallEPNS0_7IsolateENS0_6HandleINS0_6ObjectEEES6_iPS6_ (ledger-live-desktop + 0x2771e27)
                                                #24 0x0000559a996125f9 _ZN2v88Function4CallENS_5LocalINS_7ContextEEENS1_INS_5ValueEEEiPS5_ (ledger-live-desktop + 0x26765f9)
                                                #25 0x0000559a9e699d4a n/a (ledger-live-desktop + 0x76fdd4a)
                                                #26 0x0000559a9e69a08a n/a (ledger-live-desktop + 0x76fe08a)
                                                #27 0x0000559a9e6abb23 n/a (ledger-live-desktop + 0x770fb23)
                                                #28 0x0000559a9e7cd936 n/a (ledger-live-desktop + 0x7831936)
                                                #29 0x0000559a9e7cf711 n/a (ledger-live-desktop + 0x7833711)
                                                #30 0x0000559a9e7d4330 n/a (ledger-live-desktop + 0x7838330)
                                                #31 0x0000559a9889a322 n/a (ledger-live-desktop + 0x18fe322)
                                                #32 0x0000559a9889f4f1 n/a (ledger-live-desktop + 0x19034f1)
                                                #33 0x0000559a98891199 uv_run (ledger-live-desktop + 0x18f5199)
                                                #34 0x0000559a98a00d7e n/a (ledger-live-desktop + 0x1a64d7e)

My temporary solution is to simply press the Enter key and everything seems to work properly. But I want to understand and resolve this issue anyway.

Thank you for your help.

4 - File system errors left uncorrected
fsck(8): check/repair file system - Linux man page

There are errors on the disk which needs to be repaired.

Try adding this:


to the kernel parameter.

Otherwise run fsck from a live session. (I.E. Donwload any Manjaro ISO and boot from that)


Thanks @megavolt it worked for me!
Just to be sure that I did everything right:
At the boot of manjaro, I pressed the e key to edit the grub file.
At my current kernel (5.12.19-1) and at the linux /boot/vmlinuz line I added the fsck.mode=force line and after a reboot it worked and no more error message.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.