Failed to open directory

so i have a folder that whenever i try to open i get an error message and can’t open it in the file manager but when i open it with catfish search i can find everything except for one folder that is really important.
i’m new to linux and have no idea how can i fix this, help please

here is a screenshot for the error: i.imgur com/ycXQ7bR.png

Welcome at the forum, @AlphaN00b,

many helpers incl. myself don’t touch linked pictures. Your help request will be faster answered if you try to write it down what you want to express, even if this takes you a bit more time. :smiley:

1 Like

I also prefer not to look at image links, but sometimes curiosity gets the better of me.


idk why but whenever i tried to add an image i kept getting a message saying i can’t do that

I presume because you’ve only just joined and therefore don’t have the permissions to do it.

You may be able to select the text and copy/paste it though (or recreate it), which is the preferred method. Makes things easier on us, or more accurately the people who know how to help others (I’m not so good at that).

Hello @AlphaN00b :wink:

If this a physical disk and not a network mount, then I/O Errors mostly indicates that there is an error on the file system.

UNMOUNT it and try to fix that. Since you didn’t mention which file system it is, i would assume it is ext4:

sudo fsck.ext4  -cfyv /dev/sdYN

Find the correct device with:

sudo fdisk -l

Also if the hard drive has badblocks that could cause those errors, you will need to tell ext4 where the badblocks are, so that it get skipped on read/writes.

sudo fsck -vcck /dev/sdaYN

totally forgot about this, will leave the way i fixed it incase someone get a similiar situation:
apparently i kept getting errors bc the folder was on a windows formatted partition and it obviously had a corrputed file,
all i had to do is move the folder into a linux formatted partition and everything is there except for the corrupted file that kept causing it to crash.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.